<div dir="ltr">I think it still true, I guess you can hack sys.path but perhaps we don't need to worry about that </div><br><div class="gmail_quote"><div dir="ltr">On Tue, 1 Aug 2017 at 13:57 Matthew Brett <<a href="mailto:matthew.brett@gmail.com">matthew.brett@gmail.com</a>> wrote:<br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">On Tue, Aug 1, 2017 at 12:30 PM, Jens Nielsen <<a href="mailto:jenshnielsen@gmail.com" target="_blank">jenshnielsen@gmail.com</a>> wrote:<br>
> Another possible solution could be to drop the dependency on subprocess32<br>
> but retain the use of it in compat/subprocess.py and fallback to regular<br>
> subprocess if not found and then document that if a user sees<br>
> <a href="https://github.com/matplotlib/matplotlib/issues/5314" rel="noreferrer" target="_blank">https://github.com/matplotlib/matplotlib/issues/5314</a> they should install<br>
> subprocess32. There should be few issues with dropping the dependency on<br>
> Linux as the main bug it resolves is OSX specific.<br>
><br>
> Furthermore 5314 should have been resolved in python 2.7.12 so the surface<br>
> for seeing the bug on OSX is getting smaller.<br>
<br>
Excellent news!<br>
<br>
> Unfortunately Apple still<br>
> ships python 2.7.10 as the default python on OSX in Sierra (10.12)<br>
<br>
The last time I looked into this, a default install of matplotlib into<br>
system Python gets ignored because of the extra libraries "feature"<br>
<br>
<a href="https://github.com/MacPython/wiki/wiki/Which-Python#system-python-and-extra-python-packages" rel="noreferrer" target="_blank">https://github.com/MacPython/wiki/wiki/Which-Python#system-python-and-extra-python-packages</a><br>
<br>
Is that no longer true?<br>
<br>
Cheers,<br>
<br>
Matthew<br>
</blockquote></div>