[Matplotlib-users] Render plot labels with LaTeX

Ruth Sims rs803 at cam.ac.uk
Sat Apr 23 09:09:32 EDT 2016


Running Matplotlib v: 1.5.1 in Anaconda on OS X El Capitan, V 10.11.4 
trying to render plot labels with LaTeX so I can use figures in my 
thesis. However, whenever I uncomment the command 'usetex = true', I 
receive an error similar to the below:

RuntimeError: LaTeX was not able to process the following string:
'lp'
Here is the full report generated by LaTeX:

I have MacTeX-2015 and LaTeX, dvipng and ghostscript are each on my 
PATH. According to the instructions on 
https://github.com/matplotlib/matplotlib/issues/5076 
<https://github.com/matplotlib/matplotlib/issues/5076>I was able to 
reproduce the code in a clean environment - so I assume there is nothing 
wrong with any of the installations.

I've tried most of the suggestions I found on various mailing lists but 
still received the same error.

Thanks,
Ruth Sims
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/matplotlib-users/attachments/20160423/195fa45b/attachment-0003.html>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/matplotlib-users/attachments/20160423/195fa45b/attachment-0004.html>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/matplotlib-users/attachments/20160423/195fa45b/attachment-0005.html>


More information about the Matplotlib-users mailing list