<div dir="ltr">You probably have to supply some more details to figure out what is going on. I assume that you mean ipython and not numpy?<div><span style="line-height:1.5">Jupyter can run several different kernels with different versions of python so it could be a different version of python?</span><br></div><div><span style="line-height:1.5"><br></span></div><div><span style="line-height:1.5">The easies way to figure out where python imports a </span>library<span style="line-height:1.5"> from is to do something like </span></div><div><span style="line-height:1.5"><br></span></div><div><span style="line-height:1.5">import matplotlib</span></div><div>print(matplotlib.__file__)</div><div><br></div><div>that will tell you the part to the top level file of the installation. Can you try that and report back the result?</div><div><br></div><div>best</div><div>Jens</div><div><span style="line-height:1.5"><br></span></div></div><br><div class="gmail_quote"><div dir="ltr">On Thu, 10 Dec 2015 at 21:29 Joao Fonseca <<a href="mailto:joao.q.fonseca@gmail.com">joao.q.fonseca@gmail.com</a>> wrote:<br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">I don’t know if this is the place to ask but why is the matplotlib version in my Jupyter different from that in numpy? I have 1.5 installed but Jupyter imports 1.4.3.<br>
<br>
Thanks<br>
<br>
João<br>
_______________________________________________<br>
Matplotlib-users mailing list<br>
<a href="mailto:Matplotlib-users@python.org" target="_blank">Matplotlib-users@python.org</a><br>
<a href="https://mail.python.org/mailman/listinfo/matplotlib-users" rel="noreferrer" target="_blank">https://mail.python.org/mailman/listinfo/matplotlib-users</a><br>
</blockquote></div>