<html xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta name="Generator" content="Microsoft Word 15 (filtered medium)">
<style><!--
/* Font Definitions */
@font-face
        {font-family:"Cambria Math";
        panose-1:2 4 5 3 5 4 6 3 2 4;}
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0in;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri",sans-serif;}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:blue;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:purple;
        text-decoration:underline;}
p.msonormal0, li.msonormal0, div.msonormal0
        {mso-style-name:msonormal;
        mso-margin-top-alt:auto;
        margin-right:0in;
        mso-margin-bottom-alt:auto;
        margin-left:0in;
        font-size:11.0pt;
        font-family:"Calibri",sans-serif;}
span.EmailStyle18
        {mso-style-type:personal-reply;
        font-family:"Calibri",sans-serif;
        color:windowtext;}
.MsoChpDefault
        {mso-style-type:export-only;
        font-size:10.0pt;
        font-family:"Calibri",sans-serif;}
@page WordSection1
        {size:8.5in 11.0in;
        margin:1.0in 1.0in 1.0in 1.0in;}
div.WordSection1
        {page:WordSection1;}
--></style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
<o:idmap v:ext="edit" data="1" />
</o:shapelayout></xml><![endif]-->
</head>
<body lang="EN-US" link="blue" vlink="purple">
<div class="WordSection1">
<p class="MsoNormal">Thanks for the respone.  Sadly, I can’t get anything useful out of the doc.  And %matplotlib doesn’t help, same effect.<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">This is very frustrating.  I don’t know how to debug this.  It’s just a “black box”, I do what I’m “supposed to”, doesn’t work.<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">Help appreciated!<o:p></o:p></p>
<p class="MsoNormal">Dave<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal"><b>From:</b> Thomas Caswell [mailto:tcaswell@gmail.com] <br>
<b>Sent:</b> Saturday, August 05, 2017 10:36 AM<br>
<b>To:</b> Strozzi, David J. <strozzi2@llnl.gov>; matplotlib-users@python.org<br>
<b>Subject:</b> Re: [Matplotlib-users] Windows7: figure window "not responding"<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<div>
<p class="MsoNormal">I do exactly this as well (but on linux)!<o:p></o:p></p>
<div>
<p class="MsoNormal"><o:p> </o:p></p>
</div>
<div>
<p class="MsoNormal">The symptoms your are describing sounds like the GUI event loop is not being spun behind the scenes (see <a href="https://github.com/matplotlib/matplotlib/pull/4779">https://github.com/matplotlib/matplotlib/pull/4779</a> for some draft
 text at explaining how all of that works).  Have you tried doing `%matplotlib` is IPython?  <o:p></o:p></p>
</div>
<div>
<p class="MsoNormal"><o:p> </o:p></p>
</div>
<div>
<p class="MsoNormal">Tom<o:p></o:p></p>
</div>
</div>
<p class="MsoNormal"><o:p> </o:p></p>
<div>
<div>
<p class="MsoNormal">On Sat, Aug 5, 2017 at 12:39 PM Strozzi, David J. <<a href="mailto:strozzi2@llnl.gov">strozzi2@llnl.gov</a>> wrote:<o:p></o:p></p>
</div>
<blockquote style="border:none;border-left:solid #CCCCCC 1.0pt;padding:0in 0in 0in 6.0pt;margin-left:4.8pt;margin-top:5.0pt;margin-right:0in;margin-bottom:5.0pt">
<div>
<div id="m_5400856808711202163divtagdefaultwrapper">
<p><span style="font-size:12.0pt;color:black">This problem has been driving me nuts, posted it elsewhere, so far no one's been able to help.  I am running Python 3.6.1 from Anaconda (all packages updated to latest and greatest) on Windows 7.  ipython and mpl
 figure windows work fine from a console, or spyder.  The problem is when I try running ipython within emacs using elpy.<o:p></o:p></span></p>
<p><span style="font-size:12.0pt;color:black"><o:p> </o:p></span></p>
<p><span style="font-size:12.0pt;color:black">To back up, the workflow I'm shooting for is using emacs as my IDE, and running python within emacs.  I've done this for many years with the Yorick interpreter, and it's quite addictive.  I get the same problem
 whether I use the GNU windows build of emacs, or emacs -nw (terminal, no X) from cygwin (ver 25.2 both cases).  elpy seems to be a good Python package for emacs, and nominally supports using ipython.<o:p></o:p></span></p>
<p><span style="font-size:12.0pt;color:black"><o:p> </o:p></span></p>
<p><span style="font-size:12.0pt;color:black">OK, so - I can use ipython + emacs + elpy.  The only problem is matplotlib figures.  When I do figure(), a figure window appears, but is not fully rendered (e.g. no buttons), and the window title says "Not responding". 
 If I do a plot(), nothing is plotted.  Playing with ion() and show() doesn't help.<o:p></o:p></span></p>
<p><span style="font-size:12.0pt;color:black"><o:p> </o:p></span></p>
<p><span style="font-size:12.0pt;color:black">I've posted this on the elpy github, various stackexchange forums, no one has had any ideas yet.<o:p></o:p></span></p>
<p><span style="font-size:12.0pt;color:black"><o:p> </o:p></span></p>
<p><span style="font-size:12.0pt;color:black">Any help is greatly appreciated!<o:p></o:p></span></p>
<p><span style="font-size:12.0pt;color:black">Dave<o:p></o:p></span></p>
</div>
</div>
<p class="MsoNormal">_______________________________________________<br>
Matplotlib-users mailing list<br>
<a href="mailto:Matplotlib-users@python.org" target="_blank">Matplotlib-users@python.org</a><br>
<a href="https://mail.python.org/mailman/listinfo/matplotlib-users" target="_blank">https://mail.python.org/mailman/listinfo/matplotlib-users</a><o:p></o:p></p>
</blockquote>
</div>
</div>
</body>
</html>