<html xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta name="Generator" content="Microsoft Word 15 (filtered medium)">
<style><!--
/* Font Definitions */
@font-face
        {font-family:Wingdings;
        panose-1:5 0 0 0 0 0 0 0 0 0;}
@font-face
        {font-family:"Cambria Math";
        panose-1:2 4 5 3 5 4 6 3 2 4;}
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0in;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri",sans-serif;}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:blue;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:purple;
        text-decoration:underline;}
p.msonormal0, li.msonormal0, div.msonormal0
        {mso-style-name:msonormal;
        mso-margin-top-alt:auto;
        margin-right:0in;
        mso-margin-bottom-alt:auto;
        margin-left:0in;
        font-size:11.0pt;
        font-family:"Calibri",sans-serif;}
span.EmailStyle18
        {mso-style-type:personal;
        font-family:"Calibri",sans-serif;
        color:windowtext;}
span.EmailStyle21
        {mso-style-type:personal-reply;
        font-family:"Calibri",sans-serif;
        color:windowtext;}
.MsoChpDefault
        {mso-style-type:export-only;
        font-size:10.0pt;}
@page WordSection1
        {size:8.5in 11.0in;
        margin:1.0in 1.0in 1.0in 1.0in;}
div.WordSection1
        {page:WordSection1;}
--></style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
<o:idmap v:ext="edit" data="1" />
</o:shapelayout></xml><![endif]-->
</head>
<body lang="EN-US" link="blue" vlink="purple">
<div class="WordSection1">
<p class="MsoNormal">Hope this appears in the thread.  I still haven’t solved this issue, trying to bump this to the top of someone’s stack.  No one responded to this message.<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">Any help appreciated.  Thanks.<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">Dave<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<div>
<div style="border:none;border-top:solid #E1E1E1 1.0pt;padding:3.0pt 0in 0in 0in">
<p class="MsoNormal"><b>From:</b> Matplotlib-users [mailto:matplotlib-users-bounces+strozzi2=llnl.gov@python.org]
<b>On Behalf Of </b>Strozzi, David J.<br>
<b>Sent:</b> Monday, August 28, 2017 1:48 PM<br>
<b>To:</b> Thomas Caswell <tcaswell@gmail.com>; matplotlib-users@python.org<br>
<b>Subject:</b> Re: [Matplotlib-users] Windows7: figure window "not responding"<o:p></o:p></p>
</div>
</div>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">Sorry for the delay.  Life, work, etc. intervene.  I tried tk backend, failed but in a different way.  Seems to get “farther” in that I can get a plot to render.<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">* Versions (all very recent from Anaconda): Python: 3.6.2  ipython: 6.1.0  matplotlib: 2.0.2<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">* My emacs startup has (elpy-use-ipython).<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">* With backend ‘TkAgg’:<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">plt.ion()<o:p></o:p></p>
<p class="MsoNormal">figure(1)  <span style="font-family:Wingdings">à</span> window appears, with buttons on bottom (doesn’t happen with ‘Qt5Agg’ backend.  ipyton prompt works.  But, if I try interacting with the figure window, I get “not responding” in title,
 and windows’ spinning shell.  If I close the figure window by clicking on the X in upper right, windows says “app not responding.”  Dialog box w/ End Process or Cancel.  End process kills figure and ipython session.<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">plt.ioff() instead:<o:p></o:p></p>
<p class="MsoNormal">figure(1)<o:p></o:p></p>
<p class="MsoNormal">plot(1,1)<o:p></o:p></p>
<p class="MsoNormal">show()<o:p></o:p></p>
<p class="MsoNormal">I get a figure window with a plot, but if I interact with it I get “not responding.”  ipython prompt seems fine.  I can close window from prompt close(1) and ipython fine.<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">Help appreciated!  I hopefully won’t wait so long to respond.<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">Thanks,<o:p></o:p></p>
<p class="MsoNormal">Dave<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal"><b>From:</b> Thomas Caswell [<a href="mailto:tcaswell@gmail.com">mailto:tcaswell@gmail.com</a>]
<br>
<b>Sent:</b> Saturday, August 19, 2017 2:32 PM<br>
<b>To:</b> Strozzi, David J. <<a href="mailto:strozzi2@llnl.gov">strozzi2@llnl.gov</a>>;
<a href="mailto:matplotlib-users@python.org">matplotlib-users@python.org</a><br>
<b>Subject:</b> Re: [Matplotlib-users] Windows7: figure window "not responding"<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<div>
<p class="MsoNormal">That is at least all consistent!  The issue as that for what ever reason the input hook is not being set up correctly (which is what lets the GUI event loop spin and process events while the terminal waits for you to type).  With `plt.ion()`
 the terminal is blocking the process waiting for you to type (which is why the window is not responding), with `plt.ioff()` when you do `plt.show()` the GUI event loop is blocking the process (which is why it works, but you don't get the next prompt back until
 you close the plot window).  Again, see <a href="https://github.com/matplotlib/matplotlib/pull/4779">https://github.com/matplotlib/matplotlib/pull/4779</a> for a longer pass at explaining how this all works (and I would appreciate feed back about where it
 does not make sense!).<o:p></o:p></p>
<div>
<p class="MsoNormal"><o:p> </o:p></p>
<div>
<p class="MsoNormal">Try using `tkagg` as the backend, the integration between python and tk in a bit tighter (because it is done in the cpython source). <o:p></o:p></p>
</div>
<div>
<p class="MsoNormal"><o:p> </o:p></p>
</div>
<div>
<p class="MsoNormal">Which version of IPython and matplotlib are you using (and are you sure that elpy is using the versions you think it is?)?<o:p></o:p></p>
</div>
<div>
<p class="MsoNormal"><o:p> </o:p></p>
</div>
<div>
<p class="MsoNormal">are you using `(elpy-use-ipython)` or just hacking the python executable path?<o:p></o:p></p>
</div>
<div>
<p class="MsoNormal"><o:p> </o:p></p>
</div>
<div>
<p class="MsoNormal">You are siting at a very interesting intersection of technology here (emacs + python + GUI + windows).  It might make sense to ask either on the elpy mailing list or the ipython mailing list.<o:p></o:p></p>
</div>
</div>
<div>
<p class="MsoNormal"><o:p> </o:p></p>
</div>
<div>
<p class="MsoNormal">Tom<o:p></o:p></p>
</div>
</div>
<p class="MsoNormal"><o:p> </o:p></p>
<div>
<div>
<p class="MsoNormal">On Sat, Aug 19, 2017 at 3:28 PM Strozzi, David J. <<a href="mailto:strozzi2@llnl.gov">strozzi2@llnl.gov</a>> wrote:<o:p></o:p></p>
</div>
<blockquote style="border:none;border-left:solid #CCCCCC 1.0pt;padding:0in 0in 0in 6.0pt;margin-left:4.8pt;margin-top:5.0pt;margin-right:0in;margin-bottom:5.0pt">
<div>
<div>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto">Hi,<o:p></o:p></p>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"> <o:p></o:p></p>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto">* Just subscribed to list.<o:p></o:p></p>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"> <o:p></o:p></p>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto">* Backend: mpl.get_backend() = ‘Qt5Agg’.  I am not committed to this if another one will work.<o:p></o:p></p>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"> <o:p></o:p></p>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto">* “If you get up a window:” I start ipython within emacs (the GNU win32 build, not cygwin), and do figure(1), a figure window appears, but nothing renders, and window title bar
 says “Not responding.”  If I plot something, it doesn’t appear.<o:p></o:p></p>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"> <o:p></o:p></p>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto">fig is not defined, by default.  I can do fig=gcf().  Then fig.canvas.flush_events() has an interesting effect – the plot appears, but then window title still says “not responding”
 and when I hover the mouse over the figure window it becomes Windows’ spinning blue circle (the busy symbol, like Mac’s spinning beachball).<o:p></o:p></p>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"> <o:p></o:p></p>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto">“control” is returned to ipython.  I can continue to execute commands there.<o:p></o:p></p>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"> <o:p></o:p></p>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto">* At this point, plt.ioff() doesn’t seem to do anything.  plt.show() does – “not responding” disappears, the figure window works like normal.  Buttons on it work.  But the ipython
 window is “frozen” no In[] prompt.<o:p></o:p></p>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"> <o:p></o:p></p>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto">OK so this seems like a lot of information.  Maybe we can make progress?<o:p></o:p></p>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"> <o:p></o:p></p>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto">Dave<o:p></o:p></p>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"> <o:p></o:p></p>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"> <o:p></o:p></p>
</div>
</div>
<div>
<div>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"><b>From:</b> Thomas Caswell [mailto:<a href="mailto:tcaswell@gmail.com" target="_blank">tcaswell@gmail.com</a>]
<o:p></o:p></p>
</div>
</div>
<div>
<div>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"><b>Sent:</b> Saturday, August 19, 2017 10:54 AM<o:p></o:p></p>
</div>
</div>
<div>
<div>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"><br>
<b>To:</b> Strozzi, David J. <<a href="mailto:strozzi2@llnl.gov" target="_blank">strozzi2@llnl.gov</a>>;
<a href="mailto:matplotlib-users@python.org" target="_blank">matplotlib-users@python.org</a><br>
<b>Subject:</b> Re: [Matplotlib-users] Windows7: figure window "not responding"<o:p></o:p></p>
</div>
</div>
<div>
<div>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"> <o:p></o:p></p>
<div>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto">David,<o:p></o:p></p>
<div>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"> <o:p></o:p></p>
</div>
<div>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto">Please subscribe to the mailing list so you can post un-moderated.<o:p></o:p></p>
</div>
<div>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"> <o:p></o:p></p>
</div>
<div>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto">Which backend are you using?<o:p></o:p></p>
</div>
<div>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"> <o:p></o:p></p>
</div>
<div>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto">If you get a window up and then do `fig.canvas.flush_events()` will it update?<o:p></o:p></p>
</div>
<div>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"> <o:p></o:p></p>
</div>
<div>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto">If you do `plt.ioff()` and then `plt.show()` does it work?<o:p></o:p></p>
</div>
<div>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"> <o:p></o:p></p>
</div>
<div>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto">Tom<o:p></o:p></p>
</div>
<div>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"> <o:p></o:p></p>
</div>
</div>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"> <o:p></o:p></p>
<div>
<div>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto">On Sat, Aug 19, 2017 at 12:40 PM Strozzi, David J. <<a href="mailto:strozzi2@llnl.gov" target="_blank">strozzi2@llnl.gov</a>> wrote:<o:p></o:p></p>
</div>
<blockquote style="border:none;border-left:solid #CCCCCC 1.0pt;padding:0in 0in 0in 6.0pt;margin-left:4.8pt;margin-top:5.0pt;margin-right:0in;margin-bottom:5.0pt">
<div>
<div>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto">Thanks for the respone.  Sadly, I can’t get anything useful out of the doc.  And %matplotlib doesn’t help, same effect.<o:p></o:p></p>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"> <o:p></o:p></p>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto">This is very frustrating.  I don’t know how to debug this.  It’s just a “black box”, I do what I’m “supposed to”, doesn’t work.<o:p></o:p></p>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"> <o:p></o:p></p>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto">Help appreciated!<o:p></o:p></p>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto">Dave<o:p></o:p></p>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"> <o:p></o:p></p>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"><b>From:</b> Thomas Caswell [mailto:<a href="mailto:tcaswell@gmail.com" target="_blank">tcaswell@gmail.com</a>]
<br>
<b>Sent:</b> Saturday, August 05, 2017 10:36 AM<br>
<b>To:</b> Strozzi, David J. <<a href="mailto:strozzi2@llnl.gov" target="_blank">strozzi2@llnl.gov</a>>;
<a href="mailto:matplotlib-users@python.org" target="_blank">matplotlib-users@python.org</a><br>
<b>Subject:</b> Re: [Matplotlib-users] Windows7: figure window "not responding"<o:p></o:p></p>
</div>
</div>
<div>
<div>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"> <o:p></o:p></p>
<div>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto">I do exactly this as well (but on linux)!<o:p></o:p></p>
<div>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"> <o:p></o:p></p>
</div>
<div>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto">The symptoms your are describing sounds like the GUI event loop is not being spun behind the scenes (see <a href="https://github.com/matplotlib/matplotlib/pull/4779" target="_blank">https://github.com/matplotlib/matplotlib/pull/4779</a> for
 some draft text at explaining how all of that works).  Have you tried doing `%matplotlib` is IPython?  <o:p></o:p></p>
</div>
<div>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"> <o:p></o:p></p>
</div>
<div>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto">Tom<o:p></o:p></p>
</div>
</div>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"> <o:p></o:p></p>
<div>
<div>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto">On Sat, Aug 5, 2017 at 12:39 PM Strozzi, David J. <<a href="mailto:strozzi2@llnl.gov" target="_blank">strozzi2@llnl.gov</a>> wrote:<o:p></o:p></p>
</div>
<blockquote style="border:none;border-left:solid #CCCCCC 1.0pt;padding:0in 0in 0in 6.0pt;margin-left:4.8pt;margin-top:5.0pt;margin-right:0in;margin-bottom:5.0pt">
<div>
<div id="m_-7380249229202294694m_2691066348535366900m_5400856808711202163divtagdefaultwrapper">
<p><span style="font-size:12.0pt;color:black">This problem has been driving me nuts, posted it elsewhere, so far no one's been able to help.  I am running Python 3.6.1 from Anaconda (all packages updated to latest and greatest) on Windows 7.  ipython and mpl
 figure windows work fine from a console, or spyder.  The problem is when I try running ipython within emacs using elpy.</span><o:p></o:p></p>
<p><span style="font-size:12.0pt;color:black"> </span><o:p></o:p></p>
<p><span style="font-size:12.0pt;color:black">To back up, the workflow I'm shooting for is using emacs as my IDE, and running python within emacs.  I've done this for many years with the Yorick interpreter, and it's quite addictive.  I get the same problem
 whether I use the GNU windows build of emacs, or emacs -nw (terminal, no X) from cygwin (ver 25.2 both cases).  elpy seems to be a good Python package for emacs, and nominally supports using ipython.</span><o:p></o:p></p>
<p><span style="font-size:12.0pt;color:black"> </span><o:p></o:p></p>
<p><span style="font-size:12.0pt;color:black">OK, so - I can use ipython + emacs + elpy.  The only problem is matplotlib figures.  When I do figure(), a figure window appears, but is not fully rendered (e.g. no buttons), and the window title says "Not responding". 
 If I do a plot(), nothing is plotted.  Playing with ion() and show() doesn't help.</span><o:p></o:p></p>
<p><span style="font-size:12.0pt;color:black"> </span><o:p></o:p></p>
<p><span style="font-size:12.0pt;color:black">I've posted this on the elpy github, various stackexchange forums, no one has had any ideas yet.</span><o:p></o:p></p>
<p><span style="font-size:12.0pt;color:black"> </span><o:p></o:p></p>
<p><span style="font-size:12.0pt;color:black">Any help is greatly appreciated!</span><o:p></o:p></p>
<p><span style="font-size:12.0pt;color:black">Dave</span><o:p></o:p></p>
</div>
</div>
<p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto">_______________________________________________<br>
Matplotlib-users mailing list<br>
<a href="mailto:Matplotlib-users@python.org" target="_blank">Matplotlib-users@python.org</a><br>
<a href="https://mail.python.org/mailman/listinfo/matplotlib-users" target="_blank">https://mail.python.org/mailman/listinfo/matplotlib-users</a><o:p></o:p></p>
</blockquote>
</div>
</div>
</div>
</blockquote>
</div>
</div>
</div>
</blockquote>
</div>
</div>
</body>
</html>