<div dir="ltr"><div class="gmail_default" style="font-family:tahoma,sans-serif;font-size:small">The platform is Suse Linux Enterprise Server 12.</div><div class="gmail_default" style="font-family:tahoma,sans-serif;font-size:small">Also, I checked and there are no modules loaded:</div><div class="gmail_default" style="font-family:tahoma,sans-serif;font-size:small"><div class="gmail_default">> module list</div><div class="gmail_default">No Modulefiles Currently Loaded.</div><div class="gmail_default"><br></div><div class="gmail_default">I also checked that I was launching the anaconda version of python/ipython.</div></div><div class="gmail_extra"><br></div><div class="gmail_extra"><div class="gmail_default" style="font-family:tahoma,sans-serif;font-size:small">​To be more explicit about the error, if I use in my matplotlibrc:</div><div class="gmail_default" style="font-family:tahoma,sans-serif;font-size:small">​backend      : Qt5Agg</div><div class="gmail_default"><font face="tahoma, sans-serif">backend.qt4 : PyQt4</font><br></div><div class="gmail_default"><font face="tahoma, sans-serif"><br></font></div><div class="gmail_default"><font face="tahoma, sans-serif">Then when I start up ipython with the --pylab argument, I get:</font></div><div class="gmail_default"><font face="tahoma, sans-serif"><div class="gmail_default">[TerminalIPythonApp] WARNING | Eventloop or matplotlib integration failed. Is matplotlib installed?</div><div class="gmail_default">---------------------------------------------------------------------------</div><div class="gmail_default">ImportError                               Traceback (most recent call last)</div><div class="gmail_default">/u/jdslavin/anaconda2/lib/python2.7/site-packages/IPython/core/shellapp.pyc in <lambda>(key)</div><div class="gmail_default">    196         shell = self.shell</div><div class="gmail_default">    197         if self.pylab:</div><div class="gmail_default">--> 198             enable = lambda key: shell.enable_pylab(key, import_all=self.pylab_import_all)</div><div class="gmail_default">    199             key = self.pylab</div><div class="gmail_default">    200         elif self.matplotlib:</div><div class="gmail_default">...</div><div class="gmail_default">(snipped)</div><div class="gmail_default"><br></div><div class="gmail_default">/u/jdslavin/anaconda2/lib/python2.7/site-packages/matplotlib/backends/qt_compat.py in <module>()</div><div class="gmail_default">    135     if QT_API == QT_API_PYQT5:</div><div class="gmail_default">    136         try:</div><div class="gmail_default">--> 137             from PyQt5 import QtCore, QtGui, QtWidgets</div><div class="gmail_default">    138             _getSaveFileName = QtWidgets.QFileDialog.getSaveFileName</div><div class="gmail_default">    139         except ImportError:</div><div class="gmail_default"><br></div><div class="gmail_default">ImportError: /lib64/libpthread.so.0: version `GLIBC_2.12' not found (required by /u/jdslavin/anaconda2/lib/python2.7/site-packages/PyQt5/../../.././libglib-2.0.so.0)</div><div><br></div><div>So I'm guessing that this has to do with the version of glibc installed rather than the missing gui toolkits as I had previously thought.  It could be that loading some module might fix the problem, though I'm not sure if that's true or which one I'd need to load.</div><div>Any ideas?</div><div><br></div><div>Jon</div></font></div><br><div class="gmail_quote">On Sun, Feb 4, 2018 at 10:28 AM,  <span dir="ltr"><<a href="mailto:matplotlib-users-request@python.org" target="_blank">matplotlib-users-request@python.org</a>></span> wrote:<blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">
Date: Sun, 4 Feb 2018 16:12:20 +0100<br>
From: Jerzy Karczmarczuk <<a href="mailto:jerzy.karczmarczuk@unicaen.fr">jerzy.karczmarczuk@unicaen.fr</a><wbr>><br>
To: <a href="mailto:matplotlib-users@python.org">matplotlib-users@python.org</a><br>
Subject: Re: [Matplotlib-users] backend for matplotlib on NAS Lou<br>
Message-ID: <<a href="mailto:ac90dd6e-f292-84fa-7e54-e8779a531e6c@unicaen.fr">ac90dd6e-f292-84fa-7e54-<wbr>e8779a531e6c@unicaen.fr</a>><br>
Content-Type: text/plain; charset=utf-8; format=flowed<br><br><br>
Please, tell what is your platform, under which system. Which Python<br>
version.<br>
You seem not believing me that you may have conflicts between various QT<br>
instances. Perhaps...? Verify *all* the occurrences of your libraries<br>
susceptible of being used by the mpl backend variants. Use 'which',<br>
'where', 'locate', etc., all that goes on your system.<br>
First of all, you must ensure and be certain that you launch what you<br>
think you do, and not some "parasites".<br>
BTW. I didn't use "show()" for a long time, plt.plot(...) plots, and<br>
that's it.<br>
<br>
All the best<br>
<br>
Jerzy<br>
<br>
------------------------------<br>
<br>
Message: 3<br>
Date: Sun, 04 Feb 2018 15:22:29 +0000<br>
From: Nathan Goldbaum <<a href="mailto:nathan12343@gmail.com">nathan12343@gmail.com</a>><br>
To: Jerzy Karczmarczuk <<a href="mailto:jerzy.karczmarczuk@unicaen.fr">jerzy.karczmarczuk@unicaen.fr</a><wbr>><br>
Cc: <a href="mailto:matplotlib-users@python.org">matplotlib-users@python.org</a><br>
Subject: Re: [Matplotlib-users] backend for matplotlib on NAS Lou<br>
Message-ID:<br>
        <<wbr>CAJXewOkyWqatumYFLLBsuSpOC2OzM<wbr>x_zHmQ6O0=<a href="mailto:91T3ewYo%2BSA@mail.gmail.com">91T3ewYo+SA@mail.<wbr>gmail.com</a>><br>
Content-Type: text/plain; charset="utf-8"<br>
<br>
I would also unload all modules you have loaded, if Lou has a module system<br>
installed. In the past I?ve found that the module system used on HPC<br>
systems can defeat the rpath trickery that conda uses to associate an<br>
extension module with a python package.<br></blockquote></div>-- <br><div class="gmail_signature"><div dir="ltr"><div><div dir="ltr">________________________________________________________<br>Jonathan D. Slavin                 Harvard-Smithsonian CfA<br><a href="mailto:jslavin@cfa.harvard.edu" target="_blank">jslavin@cfa.harvard.edu</a>       60 Garden Street, MS 83<br>phone: (617) 496-7981       Cambridge, MA 02138-1516<br>cell: (781) 363-0035             USA<br>________________________________________________________<br><br></div></div></div></div>
</div></div>