[PYTHON MATRIX-SIG] Release 0.20 of matrix object is available
Hinsen Konrad
hinsenk@ere.umontreal.ca
Sat, 9 Dec 1995 11:05:43 -0500
interesting one. While I favor names like IntegerMatrix, ..., reserving
Matrix to be a "smart" operator that decides on the type from the
arguments, there is a place for a version with a calculable type or type
code, so that one can get different things on different platforms with
the same source by doing tests on the system type.
The "smart" version could take an optional argument indicating the type
somehow. In addition to the typecodes, it would be nice if it would
accept the return values of the builtin function type() . Then you
could write something like
list = [1,3,2]
Array(list, type(list[0]))
The typecode will still be needed for the types that have no Python
equivalents, like C-floats.
I think Array is a better name than Matrix and if 'array' weren't
already taken would have no hesitation in going ahead. If we picked
Once more, it is only the module name "array" that we can't use. Nothing
else is global in Python.
Array as the name that is now Matrix, what would we call that which is
now 'matrix'? ArrayFromSequence ?
I still propose that "Array" should behave like "matrix" does now.
That way we need only one constructor.
-------------------------------------------------------------------------------
Konrad Hinsen | E-Mail: hinsenk@ere.umontreal.ca
Departement de chimie | Tel.: +1-514-343-6111 ext. 3953
Universite de Montreal | Fax: +1-514-343-7586
C.P. 6128, succ. Centre-Ville | Deutsch/Esperanto/English/Nederlands/
Montreal (QC) H3C 3J7 | Francais (phase experimentale)
-------------------------------------------------------------------------------
=================
MATRIX-SIG - SIG on Matrix Math for Python
send messages to: matrix-sig@python.org
administrivia to: matrix-sig-request@python.org
=================