[PYTHON MATRIX-SIG] Re: Strange behaviour with make.

tim@lassi.ece.uiuc.edu tim@lassi.ece.uiuc.edu
Tue, 13 Aug 1996 18:41:20 -0500

I though I'd mention this to see if anyone else had this problem:

When I first tried to make the Numeric, 
make Makefile -f Makefile.pre.in
sent my machine into infinite loop.

I mucked around a bit and got it to work. However, when I tried to
recreate it I got stumped. Once I unpacked it fresh and it looped
again. When I copied the Makefile.pre.in from the working version of
NumPy over, it worked.

"AH HA! I just need to dof a diff and I'll know the problem."  So I
did a diff against the original and there was NO DIFFERENCE. So I
unpacked NumPy again into another directory and this time it worked.
And it worked several more times. So now I'm stumped.

Did anyone else see this? 

On a different note: zeros is sort of uninformative if you give it a
number instead of a tuple (an easy mistake...).
>>> from Numeric import *
>>> zeros(5)
Traceback (innermost last):
  File "<stdin>", line 1, in ?
AttributeError: __len__
>>> zeros((5))
Traceback (innermost last):
  File "<stdin>", line 1, in ?
AttributeError: __len__
>>> zeros((5,))
0 0 0 0 0


| Tim Hochberg               Ultrahigh Speed Digital Electronics Lab |
| tim@lassi.ece.uiuc.edu              University of Illinois         |
| http://dogbert.ece.uiuc.edu/~tim         (217) 333-6014            |

MATRIX-SIG  - SIG on Matrix Math for Python

send messages to: matrix-sig@python.org
administrivia to: matrix-sig-request@python.org