[PYTHON MATRIX-SIG] Last complaints about NumPy 1.0a5
Konrad Hinsen
hinsen@ibs.ibs.fr
Wed, 23 Oct 96 14:27:43 +0100
Reading David's excellent tutorial has made me aware of a few
peculiarities that I had forgotten, and which should be cleaned
up before the beta release:
1) where() is just a special case of choose() and should be
eliminated.
2) compress() is just a special case of repeat() and should be
eliminated.
3) binarysearch() should be called just search(), or find().
The name of a function should not indicate the algorithm
that is uses, however obvious the choice of the algorithm
is.
4) I am a bit confused about the exact meaning of the parameters
to diagonal() and trace(). Shouldn't that simply be to integers,
indicating the two axes along which the diagonal is constructed,
and defaulting to -2 and -1?
5) There's dot() and matrixmultiply(). Dot() does something for which
I have never found a direct need, and which anyway should not be
called dot() because it doesn't work like what linear algebra
users expect dot() to mean. How about having just dot() with a
useful generalization of the dot product, i.e. summing along
the last axis of the first and the first axis of the second argument?
(I think we have discussed this before, but I don't remember details...)
Konrad.
--
-------------------------------------------------------------------------------
Konrad Hinsen | E-Mail: hinsen@ibs.ibs.fr
Laboratoire de Dynamique Moleculaire | Tel.: +33-76.88.99.28
Institut de Biologie Structurale | Fax: +33-76.88.54.94
41, av. des Martyrs | Deutsch/Esperanto/English/
38027 Grenoble Cedex 1, France | Nederlands/Francais
-------------------------------------------------------------------------------
=================
MATRIX-SIG - SIG on Matrix Math for Python
send messages to: matrix-sig@python.org
administrivia to: matrix-sig-request@python.org
=================