[Matrix-SIG] Re: [C++-SIG] CXX (Release 8) and EGCS 1.1.1

Paul F. Dubois dubois1@llnl.gov
Thu, 11 Mar 1999 15:57:06 -0800

I have now learned enough Linux that I installed EGCS 1.1.1 and tried to
compile CXX, but even with some corrections to deal with the std:: problem
and the error you got, I still get internal compiler errors. I will look
into this some more. One correspondent cleverly worked around the errors but
broke the code by removing a virtual behavior. Since the error is in a
virtual function in a templated class, it is at least believable that there
is a compiler error.

g++ -fpic  -I./Include -I./Demo -g  -I/usr/local/beta/dubois/stockpython/inc
lude/python1.5 -I/usr/local/beta/dubois/stockpython/include/python1.5 -DHAVE
_CONFIG_H -c ./Demo/r.cxx
Include/CXX_Objects.h: In method `int ::Py::String::capacity() const':
In file included from Include/CXX_Extensions.h:8,
                 from Demo/r.h:3,
                 from ./Demo/r.cxx:1:
Include/CXX_Objects.h:1237: Internal compiler error.

-----Original Message-----
From: John Barnard <barnard@hustat.harvard.edu>
To: c++-sig@python.org <c++-sig@python.org>
Date: Wednesday, January 13, 1999 3:43 PM
Subject: [C++-SIG] CXX (Release 8) and EGCS 1.1.1

>Has anyone successfully used CXX (Release 8) with EGCS 1.1.1? When I
>try to compile any of the examples that are distributed with CXX I get
>the following messages:
>gcc -I/home/barnard/lib/include -I/usr/include/python1.5  arraytest.cxx
>/home/barnard/lib/include/CXX_Objects.h: In method `class ::Py::seqref<T>
>In file included from /home/barnard/lib/include/CXX_Array.h:3,
>                 from arraytest.cxx:5:
>/home/barnard/lib/include/CXX_Objects.h:923: use of class template
`template <class T> ::Py::seqref<T>' as expression
>/home/barnard/lib/include/CXX_Objects.h: In method `class ::Py::seqref<T>
>/home/barnard/lib/include/CXX_Objects.h:931: use of class template
`template <class T> ::Py::seqref<T>' as expression
>/home/barnard/lib/include/CXX_Objects.h: In method `int
::Py::String::capacity() const':
>/home/barnard/lib/include/CXX_Objects.h:1229: confused by earlier errors,
bailing out
>make: *** [all] Error 1
>I'm not sure if the problem is with the template mechanism or the
>namespace mechanism (everything that's supposed to be under the std
>namespace is in the global namespace for the libstdc++ distributed
>with EGCS 1.1.1). Turning off namespace support in CXX doesn't help.
>I'm running Red Hat 5.2 (2.0.36) on a Pentium II.
>John Barnard
>Assistant Professor
>Department of Statistics
>Harvard University
>Phone: (617) 495-1603
>Fax:   (617) 496-8057
>Email: barnard@stat.harvard.edu
>C++-SIG maillist  -  C++-SIG@python.org