[Matrix-SIG] We should rename convolve in multiarraymodule

Konrad Hinsen hinsen@cnrs-orleans.fr
Wed, 31 Mar 1999 15:39:50 +0200

> I'm suggesting that "convolve" be renamed to "correlate." as this is what
> the function actually does.  It is only the same as a true convolution if

I didn't check, because I never used this, but I agree that the names
should correspond to the actual function. I'd prefer to have both
"correlate" and "convolve", where of course one would be implemented
in terms of the other with an added reverse operation.

Konrad Hinsen                            | E-Mail: hinsen@cnrs-orleans.fr
Centre de Biophysique Moleculaire (CNRS) | Tel.: +33-
Rue Charles Sadron                       | Fax:  +33-
45071 Orleans Cedex 2                    | Deutsch/Esperanto/English/
France                                   | Nederlands/Francais