[Matrix-SIG] We should rename convolve in multiarraymodule
Paul F. Dubois
Wed, 31 Mar 1999 08:15:25 -0800
I have applied your patch. I do anything if it is easy (:->. Thanks for the
Since neither cross_correlate or convolve has a manual entry, would you be
willing to send me an entry on each?
From: Travis Oliphant <Oliphant.Travis@mayo.edu>
To: Paul F. Dubois <email@example.com>
Cc: firstname.lastname@example.org <email@example.com>
Date: Wednesday, March 31, 1999 7:28 AM
Subject: Re: [Matrix-SIG] We should rename convolve in multiarraymodule
>> FWIW I agree completely.
>I've taken the liberty to create a patch against the 11beta source to fix
>this convolve glitch. The patch renames the "convolve" in the C-code to
>cross_correlate and defines a convolve in Numeric.py that calls
>cross_correlate with the elements of the smallest argument reversed.
>This should not break any code since convolve is still defined (now
>correctly) unless that code relied on the "broken" behavior of convolve.
>Help with patch:
>If you have the patch utility, this patch can be applied by changing into
>the top-level directory of the distribution (i.e. LLNLDistribution11beta)
>patch -p1 < full_path_name_to_corr_patch
>e.g. if corr_patch is in the directory where 11beta.tgz sits then
>tar zxvf 11beta.tgz
>patch -p1 <../corr_patch