[Moin-user] Billenium bug

Adam Shand adam at personaltelco.net
Thu Sep 27 19:43:01 EDT 2001


> +        oldversions = [x[1] for x in oldversions]

this patch, specifically the line above breaks python 1.5.2 support.  i'm
not sure if you're interested in supporting older versions but this breaks
it.  i just upgraded to python 2 but others on hosted servers may not have
that luxury.

maus# python MoinMoin/wikiutil.py
  File "MoinMoin/wikiutil.py", line 155
    oldversions = [x[1] for x in oldversions]
                          ^
SyntaxError: invalid syntax

adam.





More information about the Moin-user mailing list