[Moin-user] Migrating 1.0 -> 1.1. SetLang error

Daniel Fels danielfels at linuxmail.org
Thu May 29 06:00:10 EDT 2003


I installed the moin-stable.tar.gz tarball and now my browser says:

>>>
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, root at konga.comdata.biz and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Apache/1.3.26 Server at konga Port 80
<<<

And the test says:

>>>

MoinMoin CGI Diagnosis
======================

Package "MoinMoin" successfully imported.


Traceback (innermost last):
  File "/home/mywiki/moin.cgi", line 22, in ?
    cgimain.test()
   File "/usr/lib/python2.2/site-packages/MoinMoin/cgimain.py", line 32, in test
    createRequest()
   File "/usr/lib/python2.2/site-packages/MoinMoin/cgimain.py", line 20, in createRequest
    return Request(properties)
   File "/usr/lib/python2.2/site-packages/MoinMoin/request.py", line 60, in __init__
    self.lang = i18n.getLang()
   File "/usr/lib/python2.2/site-packages/MoinMoin/i18n/__init__.py", line 119, in getLang
    if user.current.language: return user.current.language
 AttributeError: 'module' object has no attribute 'current'

<<<

What is bad with getLang ???

Thanks in advance.
-- 
______________________________________________
http://www.linuxmail.org/
Now with e-mail forwarding for only US$5.95/yr

Powered by Outblaze




More information about the Moin-user mailing list