[Moin-user] install problem, debian/stable

Michael P. Soulier msoulier at digitaltorque.ca
Sun Oct 31 03:55:01 EST 2004


On 31/10/04 Atte Andr? Jensen said:

> Hi
> 
> I'm trying to set up moin on my debian/stable server, but "it doesn't 
> work", for instance:
> 
> [root at randers oversaettelser]$ python moin.cgi
> Traceback (most recent call last):
>   File "moin.cgi", line 13, in ?
>     from MoinMoin.request import RequestCGI
>   File "/usr/lib/python2.1/site-packages/MoinMoin/request.py", line 11, 
> in ?
>     from MoinMoin import config, wikiutil
>   File "/usr/lib/python2.1/site-packages/MoinMoin/config.py", line 45, in ?
>     _cfg_defaults = {
> NameError: name 'False' is not defined
> 
> My python version:
> [root at randers oversaettelser]$ python -V
> Python 2.1.3

I'm not sure if the minimum Python version for Moin is mentioned in the
the install docs, but I found that it was at least Python 2.2.2. I'm
using 2.3.4 myself. 

I just searched backports.org and I didn't find a Python backport for
Woody. You could use apt pinning to pull it out of Sarge, or just build
it yourself from the python.org tarball. 

I'm running Sarge myself.

Mike

-- 
Michael P. Soulier <msoulier at digitaltorque.ca>
http://www.digitaltorque.ca
http://opag.ca
Jabber: msoulier at digitaltorque.ca
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://mail.python.org/pipermail/moin-user/attachments/20041031/128badd4/attachment.sig>


More information about the Moin-user mailing list