[Moin-user] Problem with being logged out in some cases....

David Cramer (Tech Pubs) dcramer at motive.com
Mon Jun 20 11:00:49 EDT 2005


That makes sense and I'm happy to tell the users that. My problem is
that logging in by hostname.motive.com is broken (while logging in by
"hostname"--i.e. not fully qualified--works). If you do a search using
our intranet's search appliance, tho, the link in the hit takes you to
hostname.motive.com. 

The problem appears to be that there's some kind of problem with another
cookie from somewhere on our intranet. If you delete all your cookies,
then you can again log in with hostname.motive.com for a while. I know
little about cookies, however, so I'm at a loss as to how to
troubleshoot. I guess I'd have to delete one cookie at a time from a
browser that's having problems until the problem goes away--then I'd
know which cookie was causing the problem anyway.

Thanks,
David 

> -----Original Message-----
> From: moin-user-admin at lists.sourceforge.net 
> [mailto:moin-user-admin at lists.sourceforge.net] On Behalf Of 
> Thomas Waldmann
> Sent: Monday, June 20, 2005 1:29 AM
> To: moin-user at lists.sourceforge.net
> Subject: Re: [Moin-user] Problem with being logged out in 
> some cases....
> 
> > We have a couple of moinmoins running on our intranet and like them 
> > very much, but have noticed one problem. If you login via the url 
> > http://hostname/wiki (either by bookmarking a page with 
> your pickle or 
> > by going to the UserPreferences page and using your pw), 
> then all is 
> > well. However, if you use http://hostname.motive.com/wiki, 
> then often 
> > you are logged back out as soon as you browse to another page
> 
> You should avoid accessing a wiki via multiple urls. When the 
> internet url works, you should be able to use it from everywhere.
> 
> If you access a wiki by multiple urls, there can be issues 
> with cookies and caching...




More information about the Moin-user mailing list