[Moin-user] tableclass / tablestyle

Bryan Weingarten Bryan.Weingarten at watchguard.com
Fri Feb 17 10:06:02 EST 2006


this is now fixed in moinmoin 1.5.2... thanks!!!!

  _____  

From: moin-user-admin at lists.sourceforge.net
[mailto:moin-user-admin at lists.sourceforge.net] On Behalf Of Bryan
Weingarten
Sent: Tuesday, January 24, 2006 3:04 PM
To: moin-user at lists.sourceforge.net
Subject: RE: [Moin-user] tableclass / tablestyle


this is still broken in moin 1.5.1
 
this bug has ruined all our project templates and pages.  we were really
this would have been fixed in 1.5.1 but it wasn't which is very
disappointing. :(   we are crossing our fingers that will be fixed in
the next minor rev.
 
thanks,
 
bryan
 
 
  _____  

From: moin-user-admin at lists.sourceforge.net
[mailto:moin-user-admin at lists.sourceforge.net] On Behalf Of Bryan
Weingarten
Sent: Wednesday, January 18, 2006 1:48 PM
To: moin-user at lists.sourceforge.net
Subject: [Moin-user] tableclass / tablestyle


i have this problem that maybe someone can help me with.
 
i added a table class in common.css:
 
table.noborder td {
 border:none;
}
 
 
with this new noborder class i can create 3 different tables in my wiki
page:
 
||<tableclass="noborder">noborder||Two||
||Three||Four||
 
||<tablestyle="background-color: aqua">aqua||Two||
||Three||Four||
 
||<tableclass="noborder" tablestyle="background-color: aqua">noborder
and aqua||Two||
||Three||Four||
 
 
all three tables work correctly with moin 1.3 and 1.5.0_beta_4.  the
last table fails with moin 1.5.0 GA.    i just tested the desktop
edition 1.3 and 1.5.0-1 and the last table also fails only with version
1.5.0-1.
 
the problem i'm seeing is with the generated HTML
 
table1 correctly generates a table element with the correct class
attribute:
<table class="noborder">
 
table 2 also correctly generates a table element with the correct style
attribute:
<table style="background-color: aqua">

table 3 incorrectly generates a table element.  it assignes the class
atribute to the value of the style attribute and doesn't even write the
style element.
<table class="background-color: aqua">
 
 
since this worked correctly in other versions of moinmoin this might be
a bug in the latest GA version unless there is some new way to do this
now.
 
 
thanks for any help you can give me to solve this.
 
bryan

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/moin-user/attachments/20060217/051d8aab/attachment.html>


More information about the Moin-user mailing list