[Moin-user] Re: 1.1 => 1.5.3 upgrade path

Thomas Waldmann tw-public at gmx.de
Fri May 19 08:57:07 EDT 2006


> Hi... I posted this a month or so ago and got no answer... is this a
> silly question? (would like to know why) Is this clearly explained
> somewhere that I missed? Or no one has a clue?

Maybe we just missed your post.

 > http://moinmoin.wikiwikiweb.de/HelpOnUpdating
 > http://moinmoin.wikiwikiweb.de/MoinMoinUpgrade
 > http://moinmoin.wikiwikiweb.de/MoinMoinRelease1.3/README.migration

Yes, those are the docs. Plus docs/CHANGES in the latest release archive.

 > From the readings above, it seems I have to go this path:
 > 1.1 => 1.2.4
 > 1.2.4 => 1.3
 > 1.3 => 1.5

If you don't have much time for one big effort, you can do this.

There are 2 things taking time:
a) converting your data dir (necessary when crossing 1.3 boundary)
b) fixing your config

If you prepare by reading those docs (also read docs/CHANGES please), 
you can do this at once in a few hours.

If you don't want to do it at once:
1) upgrade to 1.2.4 (latest 1.2 release) and run it for some time to get 
all issues resolved
2) upgrade from 1.2.4 to 1.5.current (this will be the bigger part and 
includes running the mig scripts)

I don't think you need an intermediate step in 1.3.x.

I suggest joining us on #moin on irc.freenode.net while you do it. We 
expect you to read the docs before, but we can help you in case of trouble.

 > I do have ssh access to the server, but I can't edit httpd.conf or
 > other system config files (I *can* add and edit .htaccess files,
 > however).

You need to install a new moin.cgi file (if you run std. cgi).
And of course new static files (css and img) and new MoinMoin code.

And you need to convert the data dir, check if you have enough access 
rights for that.

 > The python version that comes with the server is 2.2.3, but I'm gonna
 > install 2.4.3 before the upgrade.

Very good idea (2.3 is minimum requirement). :)

BTW: if you run non-standard macros/actions/processors/parsers/themes 
you will need to adapt them to the moin target version you want to run.




More information about the Moin-user mailing list