[Moin-user] Problem with plugins after upgrading to 1.6.0

Thomas Waldmann tw-public at gmx.de
Mon Jan 14 12:41:51 EST 2008


> I've converted one wiki (from 1.3.5) to use 1.6.0. Pages are being
> displayed OK apart from those accessing the plugin directory. Every
> access of a page containing a 3rd-party macro results in an error of the
> form:
> 
>    No module named plugin.macro.XYZ

Make sure there are all __init__.py like you see in wiki/data/plugin of 
the MoinMoin distribution archive. You can just copy them over to your 
data/plugin directory.

Also make sure you have all of the plugin/ subdirectories that are in 
the dist archive.






More information about the Moin-user mailing list