[Moin-user] 1.5.8 -> 1.6.0 "TypeError: sort() takes no keyword arguments"

Dave Hill adh at displaylink.com
Wed Jan 23 14:39:00 EST 2008


In article <18327.38014.441172.682890 at montanaro.dyndns.org>,
 skip at pobox.com wrote:

>     Sebastian> What is the required minimum version of Python to run
>     Sebastian> MoinMoin?
> 
> Given the keyword arg issue with [].sort() it appears the lowest version for
> Moin 1.6.0 is at least Python 2.4.  I haven't looked at MoinMoin
> requirements in quite awhile though.  Have you read the install/upgrade
> info?  It probably says something in there.

CHANGES says nothing since 1.5.0beta1 which requires ">= 2.3".

INSTALL.html says

"The CHANGES file in the MoinMoin archive mentions what versions are 
supported. Python 2.3 is the minimum requirement for MoinMoin 1.5, but 
we suggest you use the latest Python release version."

I haven't tried updating yet...

Dave

-- 
Dave Hill
DisplayLink (UK) Ltd





More information about the Moin-user mailing list