[Moin-user] Dependency on Python 2.5 in MoinMoin 1.7.2

Thomas Waldmann tw-public at gmx.de
Sun Oct 26 12:35:12 EDT 2008


>   File "/var/share/imswiki/moin-1.7.2/lib/MoinMoin/action/serveopenid.py", line 14
>     from openid.consumer.discover import (OPENID_1_0_TYPE,
>   SyntaxError: invalid syntax
> 
>   File "/var/share/imswiki/moin-1.7.2/lib/jabberbot/capat.py", line 53
>     ident = ('%s/%s' % (idcat, idtype) for idcat, idtype in ident)
>   SyntaxError: invalid syntax
> 
> Obviously these two modules require Python 2.5.
> 
> This is on a server running Red Hat Enterprise Linux 4 and Python 2.3.4.
> I thought MoinMoin still tried to support Python 2.3, or at least 2.4?

Yes, it should be 2.3 compatible.

The problem is when developers develop on more recent python versions
and don't test the code on 2.3.

> I will attach a minimal patch.

Thanks a lot, I will commit it to the repositories soon.






More information about the Moin-user mailing list