[Moin-user] Docutils non-root installation

Jarod Beekman jarod.beekman at gmail.com
Sat Sep 20 13:43:53 EDT 2008

I'm trying to get docutils 0.5 (2008-06-25) working with moinmoin
1.7.2.  I am on a hosted server and I had to install docutils as a
non-root user.  MoinMoin returns the message:

 "Rendering of reStructured text is not possible, please install Docutils."

This wasn't surprising and I figured that it was the result of not
having either the modules or the binaries in the correct path so I
added the following to moin.cgi:

sys.path.insert(0, '/home/mydir/local/lib/python')     # Path to the
docutils directory with modules.
os.environ['PATH'] = '$PATH:/home/mydir/local/bin'    # Path to
docutils binaries
os.environ['PYTHONPATH'] = '/home/mydir/local/lib/python'  # Same as above

and I added to .bashrc
export PATH=$PATH:/home/mydir/local/bin     # Path to docutils binaries
export PYTHONPATH=/home/mydir/local/lib/python    # Path to docutils modules

I am still getting the same error.  I've tried to enable better
logging but I don't completely understand the logging mechanism so I'm
not getting any messages about docutils or the rest parser.

I apologize if I missed something in the docs, but I've spent quite a
bit of time looking.  Any help is appreciated.  Thank you.

Jarod Beekman

More information about the Moin-user mailing list