[Moin-user] After upgrade to 1.8.1, now a second click needed to download a file

Mail@Heavy.ch mail at heavy.ch
Fri Apr 3 14:47:35 EDT 2009


Eric Johnson schrieb:
> We just completed an upgrade to MoinMoin 1.8.1 (from 1.5.8!).
> 
> Now users are complaining that getting certain attachments requires an
> extra click.
> 
> The message they're seeing is:
> 
> Current configuration does not allow embedding of the file
> BW570Training_Presentation.ppt because of its mimetype
> application/vnd.ms-powerpoint
> 
> Where do I change the configuration to allow the embedding?
> 
Hi Eric

Check the configuration mimetypes_embed, andmimetypes_xss_protect and
see this page: http://moinmo.in/HelpOnMacros/EmbedObject

Be aware that emending a proprietary software like powerpoint is no
guarantee that it works with all browser/os. Even the embedded pdf
documents gives me sometimes a pain-in-the-ass and the need to
close/restart my browser, because of that buggie pdf plugins....

I had once the problem that an apache server doesn't know the correct
mimetype and because I couldn't change this on the apache, I had to add
the correct filetype into the wikiutil.py directly (search for "mimetype
support"). but that's pity, because with every update you will loose
this stuff and need to redo/patch it.

bye
Marcel




More information about the Moin-user mailing list