[Moin-user] xapian installation

Olivier Lauret olivier.lauret at googlemail.com
Fri Jan 23 05:16:10 EST 2009

Hi Marcel,

Thank you very much for your message. Sorry if I didn't answer sooner, but I
wanted to try many things before answering back.

I've tried again (and again [?]) what you did, which is almost what I did but
I still have the same problem:

       ERROR MoinMoin.config.multiconfig:334 xapian_search was auto-disabled
because python-xapian is not installed
[/home/eohwiki/lib/python2.5/_xapian.so: undefined symbol:

It seems indeed related to the python version, which is by default 2.4 on my
server, but the wiki (reinstalled it) and the wsgi are installed using 2.5.

When installing the xapian bindings, I can see that it is checking for the
version of python and finds 2.4, but using the option
PYTHON_LIB=$HOME/lib/python2.5, it puts the xapian.py file under

When I'm in Python2.5 and do an import xapian, I get the same error message:

   >>> import xapian
   Traceback (most recent call last):
     File "<stdin>", line 1, in <module>
     File "/home/eohwiki/lib/python2.5/xapian.py", line 6, in <module>
       import _xapian
   ImportError: ./_xapian.so: undefined symbol: PyUnicodeUCS4_EncodeUTF8

When I'm in Python (therefore 2.4) and do an import xapian, it's working

The command "grep Py_UNICODE_SIZE /usr/local/include/python2.5/pyconfig.h"
give : #define Py_UNICODE_SIZE 2
The command "grep Py_UNICODE_SIZE /usr/include/python2.4/pyconfig.h" give

Any idea how I could install xapian-bindings using a specific version of


Date: Tue, 06 Jan 2009 11:42:41 +0100
From: "Mail at Heavy.ch" <mail at heavy.ch>
Subject: Re: [Moin-user] xapian installation
To: moin-user List <moin-user at lists.sourceforge.net>
Message-ID: <496335A1.50900 at heavy.ch>
Content-Type: text/plain; charset=ISO-8859-15

Olivier Lauret schrieb:
> Hello,
> I'd like know if someone can help me with a xapian installation. I'm on
> a server where I don't have root access.

I did also a Xapian installation without root access.

1. Python Installation 2.5 (but also works with 2.4) from the Source!

2. xapian-core

   * ./configure --prefix /path/user/lib/xapian/
   * make
   * make install

3. xapian-omega

   * ./configure --prefix /path/user/lib/xapian/
   * make
   * make install

4. xapian-bindings

   * ./configure --prefix /path/user/lib/xapian/
   * make
   * make install

btw. /path/user should be your $HOME Directory.

5. MoinMoin
   * python setup.py install --prefix=/path/user/local

Be also careful if you say Python Version is 2.5.2 running; but you
installed your Xapian under $HOME/lib/python2.4/site-packages. This
can't work!

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/moin-user/attachments/20090123/661c08b7/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 328.png
Type: image/png
Size: 569 bytes
Desc: not available
URL: <http://mail.python.org/pipermail/moin-user/attachments/20090123/661c08b7/attachment.png>

More information about the Moin-user mailing list