[Moin-user] email.utils in 1.9.0beta2

Thomas Waldmann tw-public at gmx.de
Sat Mar 28 07:51:40 EDT 2009


Problem will be solved soon. It is due to this (irc log):

(12:38) < ThomasWal> the emails stuff changed from py2.4 to 2.5 to
conform with pep8.

(12:39) < ThomasWal> running python 2.5 or 2.6 is no problem, because it
has some backwards compatibility support for 
                     code doing it the 2.4 way

(12:40) < ThomasWal> BUT: if your code does it the 2.5+ way and you try
to run it on 2.4, it'll fail.

(12:41) < ThomasWal> thus, the easiest fix for code that supports
running on py2.4, is to use the old way until 2.5 is 
                     required.

(12:47) < ThomasWal> mitsuhiko: http.py line 21: just use "from
email.Utils ..."







More information about the Moin-user mailing list