[Moin-user] WSGI problem

Radomir Dopieralski moinmoin at sheep.art.pl
Thu Jul 15 05:51:17 EDT 2010


On Thu, Jul 15, 2010 at 10:47 AM, Kai Jaeger <kai at aplteam.com> wrote:
> I tried to establish a VM which is almost identical with my Internet
> Server but run into trouble.
>
> I installed Python 2.6 and Moin 1.9.3 freshly. When I access the wiki
> I get a 500 error. The apache log is saying
>
> [Thu Jul 15 08:17:57 2010] [error] [client 192.168.209.131] mod_wsgi
> (pid=2976): Target WSGI script 'D:/Wikis/config/moin.wsgi' cannot be
> loaded as Python module.
> [Thu Jul 15 08:17:57 2010] [error] Traceback (most recent call last):
> [Thu Jul 15 08:17:57 2010] [error]   File "D:/Wikis/config/moin.wsgi",
> line 20, in <module>
> [Thu Jul 15 08:17:57 2010] [error]     import sys, os
> [Thu Jul 15 08:17:57 2010] [error] ImportError: No module named os
>
> I googled for this but found only some reports associated with
> updating older Moins to 1.9.x - I've installed a fresh copy of 1.9.3,
> so that doesn't fit.

Your mod_wsgi is not set up correctly, see
http://pradyumnajoshi.wordpress.com/2009/06/09/setting-up-mod_wsgi-for-apache-and-django-on-windows/


-- 
Radomir Dopieralski, http://sheep.art.pl




More information about the Moin-user mailing list