[Moin-user] Failed to run moinmoin 1.9.2 with strange 'utf8' codec can't decode byte 0xc3 error

Thomas Waldmann tw-public at gmx.de
Fri Jun 11 06:04:18 EDT 2010


> [Fri Jun 11 15:36:44 2010] [error] [client x.x.x.x]   File
> "/usr/local/lib/python2.6/site-package
> s/MoinMoin/i18n/__init__.py", line 91, in i18n_init
> [Fri Jun 11 15:36:44 2010] [error] [client x.x.x.x]
> _languages[language][key] = value.decode(               encoding)
> [Fri Jun 11 15:36:44 2010] [error] [client x.x.x.x]   File
> "/usr/local/lib/python2.6/encodings/ut               f_8.py", line 16,
> in decode
> [Fri Jun 11 15:36:44 2010] [error] [client x.x.x.x]     return
> codecs.utf_8_decode(input, errors,                True)
> [Fri Jun 11 15:36:44 2010] [error] [client x.x.x.x]
> UnicodeDecodeError: 'utf8' codec can't decode                byte 0xc3
> in position 5: unexpected end of data

That means that one or some of the translation files has non-utf8 or
corrupt content in it. Did you modify them?

Maybe find out which files are affected and fix them.

See http://master19.moinmo.in/MoinI18n/... for the master copies of
those files (they get put into MoinMoin/i18n/ by a script). Both zh and
zh-tw could need a bit more love.

(maybe also try to reproduce by just downloading moin 1.9.2 or 1.9.3
soon, unpacking it and running ./wikiserver.py from the unpacked
directory)






More information about the Moin-user mailing list