[Moin-user] Failed to run moinmoin 1.9.2 with strange 'utf8' codec can't decode byte 0xc3 error

Jiawei Zhang jiawei.1214 at gmail.com
Sat Jun 12 21:00:48 EDT 2010


1. my config/wikiconfig.py use utf-8 encoding. The file begin with firstline
"# -*- coding: utf-8 -*-".   server/moin.wsgi use ANSI encoding. The file
begin with firstline "# -*- coding: iso-8859-1 -*-" They encoding settings
all keep unchanged as they are originally. I run MoinMoin v1.91 instance on
another server. The two files on that server keep the same encoding

2. The MoinMoin installation is fresh and first time on my host. So I didn't
use --force parameter.


2010/6/12 Thomas Waldmann <tw at waldmann-edv.de>

> > I'm sure there are not any modifications to the "po" files
> > in /usr/local/lib/python2.6/site-packages/MoinMoin/i18n. The only
> > files I modified are "config/wikiconfig.py" and "server/moin.wsgi".
> Did you use any non-utf-8 encoding there?
> > At the same time I can run ./wikiserver.py from unpacked Moin 1.9.2
> > directory without problems. What's wrong?
> > BTW, My browser language is "en-us,zh-cn,zh"
> I also tried that without problems.
> Is it maybe a permissions problem?
> Did you mix some old with some new moin installation in the same
> directory?
> Did you use setup.py --force when installing?
> >
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/moin-user/attachments/20100613/5c3c1fec/attachment.html>

More information about the Moin-user mailing list