[Moin-user] Moin error

Thomas Waldmann tw-public at gmx.de
Sat May 15 18:33:26 EDT 2010


> I get "500 Internal Server Error" and Apache's log file say:
> =======================
> Traceback (most recent call last):
>    File "/usr/local/share/moin/wiki_mydomain_se/cgi-bin/moin.cgi",
> line 29, in <module>
>      from MoinMoin.server.server_cgi import CgiConfig, run
>  ImportError: No module named MoinMoin.server.server_cgi
>  Premature end of script headers: moin.cgi
> =======================
> 
> The only reason I can think of is that the server have got some
> updates that causes this but have to clue what.
> 
> - Do you have some ideas what can be wrong?

Likely your moin.cgi does not match the moin code you are running.

> Environment
> Ubunbu Server 9.10 (Jaunty)
> Moinmoin 1.8.1
> Python 2.6.2

If that is correct, you moin is quite outdated and misses some security
fixes. I suggest you upgrade to latest 1.9.x release (and also switch to
WSGI - if you run apache, install libapache2-mod-wsgi). The moin.cgi
problem will get solved by that, too. :)

If you can't switch to WSGI (or CGI via flup via WSGI) now, you could
also update to latest 1.8.x release.






More information about the Moin-user mailing list