[Moin-user] Trying to run on Python 2.7

Thomas Waldmann tw-public at gmx.de
Mon Mar 14 09:42:16 EDT 2011


On Sun, 2011-03-13 at 13:06 -0400, David wrote:
> I am running a local WiKi on my Win7 laptop.  It has  been working
> fine for several years through Windows, Python, and Moin upgrades.
> Most recently I have tried to upgrade to Python 2.7 and I have
> problems.

This is due to python version change.

You need to run "moin ... maint cleancache".

And you also may need a rather recent moin repo checkout due to a small
py 2.7 compat issue in old werkzeug versions. Or this patch:
http://hg.moinmo.in/moin/1.9/rev/a4a7f275b7b3






More information about the Moin-user mailing list