[moin-user] FeatureUnavailableError: Flint backend no longer supported

Paul Boddie paul at boddie.org.uk
Mon Oct 10 03:58:30 EDT 2016


On Monday 10. October 2016 05.36.08 Thomas Waldmann wrote:
> On 10/09/2016 09:39 PM, Bill Trost wrote:
> > I am running 814e2e2fc11f and now am constantly getting an internal
> > error updating pages. The output gives me a stack trace ending with the
> > message, "FeatureUnavailableError: Flint backend no longer supported".
> > Can I change backends, or is something more fundamentally wrong here
> > that I need to address?
> 
> This does not sound like an error message from moin.
> 
> Which moin is that? 1.9 or 2.0 repo?
> 
> Sounds a bit like from some search lib, xapian (moin 1.9) or whoosh
> (moin 2.0).

Flint is a Xapian storage type. I haven't tracked Xapian or Whoosh for a 
while, but did Whoosh ever become competitive with Xapian or Lucene either in 
terms of performance (Xapian) or index size (Lucene)? I know it was improving 
fairly quickly at one point.

Paul


More information about the moin-user mailing list