[moin-user] Looking for MiniPage macro for Moin 1.9

james.wagner at verizon.com james.wagner at verizon.com
Fri Oct 2 12:38:38 EDT 2020


The MiniPage macro is no longer working for us in all instances. Googling around I determine I need the version compatible with 1.9. I went to http://moinmo.in/MacroMarket/MiniPage and the download section shows a number of versions; all which are attachments to the page, except for the 1.9 version. That points to an external site. When I click on that, going to http://hg.moinmo.in/moin/extensions/file/tip/data/plugin/macro/MiniPage.py  I get a "502 Bad Gateway" error. Does anyone know where I can get this version of the MiniPage macro?

It is my understanding I'm getting this error due to some issues with the parameter parsing. My SystemInfo is:

Python Version: 2.7.5
MoinMoin Version: 1.9.10

The last version in MiniPage.py is: Version 1.8.4-6 refactored for 1.8.4 added parameter escaping

I'd appreciate a pointer to the newer version, or given the macro isn't that much code if someone knows "Oh, you just change line X from <this> to <this>", that would work too. :)

Thanks much,
James.


More information about the moin-user mailing list