Thomas,<div><br></div><div>1. my config/wikiconfig.py use utf-8 encoding. The file begin with firstline "# -*- coding: utf-8 -*-".   server/moin.wsgi use ANSI encoding. The file begin with firstline "# -*- coding: iso-8859-1 -*-" They encoding settings all keep unchanged as they are originally. I run MoinMoin v1.91 instance on another server. The two files on that server keep the same encoding settings.</div>
<div><br></div><div>2. The MoinMoin installation is fresh and first time on my host. So I didn't use --force parameter.</div><div><br></div><div>Thanks</div><div>Gavin<br><br><div class="gmail_quote">2010/6/12 Thomas Waldmann <span dir="ltr"><<a href="mailto:tw@waldmann-edv.de">tw@waldmann-edv.de</a>></span><br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;"><div class="im"><br>
<br>
> I'm sure there are not any modifications to the "po" files<br>
> in /usr/local/lib/python2.6/site-packages/MoinMoin/i18n. The only<br>
> files I modified are "config/wikiconfig.py" and "server/moin.wsgi".<br>
<br>
</div>Did you use any non-utf-8 encoding there?<br>
<div class="im"><br>
> At the same time I can run ./wikiserver.py from unpacked Moin 1.9.2<br>
> directory without problems. What's wrong?<br>
> BTW, My browser language is "en-us,zh-cn,zh"<br>
<br>
</div>I also tried that without problems.<br>
<br>
Is it maybe a permissions problem?<br>
<br>
Did you mix some old with some new moin installation in the same<br>
directory?<br>
<br>
Did you use setup.py --force when installing?<br>
<br>
<br>
><br>
<br>
</blockquote></div><br></div>