<html><head></head><body><div class="ydpac87f2f1yahoo-style-wrap" style="font-family: Helvetica Neue, Helvetica, Arial, sans-serif; font-size: 13px;"><div></div>
        <div>You must follow the installation docs here: <span><a href="https://moin-20.readthedocs.io/en/latest/admin/install.html" rel="nofollow" target="_blank">https://moin-20.readthedocs.io/en/latest/admin/install.html</a></span></div><div><br></div><div>Moin2 is very different from Moin 1.9.x. As Moin 2 is not released yet, there is no packaged version. So for now, clone from github, then cd to moin directory and do "python quickinstall.py" That will create the required virtual directory.</div><div><br></div>
        
        </div><div id="yahoo_quoted_8484968693" class="yahoo_quoted">
            <div style="font-family:'Helvetica Neue', Helvetica, Arial, sans-serif;font-size:13px;color:#26282a;">
                
                <div>
                    On Saturday, May 11, 2019, 9:33:45 AM MST, Renato Pontefice <renato.pontefice@gmail.com> wrote:
                </div>
                <div><br></div>
                <div><br></div>
                <div><div id="yiv1733068921"><div>Hi,<div class="yiv1733068921">I’ve download main2 from suggested link</div><div class="yiv1733068921">- Tried to install I</div><div class="yiv1733068921">-created a virtualenv</div><div class="yiv1733068921">.tried to install it on the virtuale, but I’m unable to do it.</div><div class="yiv1733068921">This is the messages I receive:</div><div class="yiv1733068921"><br clear="none" class="yiv1733068921"></div><div class="yiv1733068921" style="margin:0px;font-stretch:normal;font-size:14px;line-height:normal;font-family:Courier;color:rgb(255, 238, 149);background-color:rgb(95, 100, 92);"><span class="yiv1733068921" style="">iMac-di-Renato:moin-master renato$ python wikiconfig.py moin2/</span></div><div class="yiv1733068921" style="margin:0px;font-stretch:normal;font-size:14px;line-height:normal;font-family:Courier;color:rgb(255, 238, 149);background-color:rgb(95, 100, 92);"><span class="yiv1733068921" style="">Traceback (most recent call last):</span></div><div class="yiv1733068921" style="margin:0px;font-stretch:normal;font-size:14px;line-height:normal;font-family:Courier;color:rgb(255, 238, 149);background-color:rgb(95, 100, 92);"><span class="yiv1733068921" style="">  File "wikiconfig.py", line 36, in <module></span></div><div class="yiv1733068921" style="margin:0px;font-stretch:normal;font-size:14px;line-height:normal;font-family:Courier;color:rgb(255, 238, 149);background-color:rgb(95, 100, 92);"><span class="yiv1733068921" style="">    from moin.config.default import DefaultConfig, _default_password_checker</span></div><div class="yiv1733068921"><span class="yiv1733068921" style="color:rgb(255, 238, 149);font-family:Courier;font-size:14px;background-color:rgb(95, 100, 92);">ImportError: No module named moin.config.default</span>t</div><div class="yiv1733068921"><br clear="none" class="yiv1733068921"></div><div class="yiv1733068921">Now, I’m trying on my iMac </div><div class="yiv1733068921"><br clear="none" class="yiv1733068921"></div><div class="yiv1733068921">What I can do now? :-(</div><div class="yiv1733068921"><br clear="none" class="yiv1733068921"></div><div class="yiv1733068921">TIA</div><div class="yiv1733068921"><br clear="none" class="yiv1733068921"></div><div class="yiv1733068921">Renato<br clear="none" class="yiv1733068921"><div class="yiv1733068921yqt7934596624" id="yiv1733068921yqt94522"><div><br clear="none" class="yiv1733068921"><blockquote class="yiv1733068921" type="cite"><div class="yiv1733068921">Il giorno 10 mag 2019, alle ore 15:58, Roger Haase <<a rel="nofollow" shape="rect" class="yiv1733068921" ymailto="mailto:crosseyedpenguin@yahoo.com" target="_blank" href="mailto:crosseyedpenguin@yahoo.com">crosseyedpenguin@yahoo.com</a>> ha scritto:</div><br clear="none" class="yiv1733068921Apple-interchange-newline"><div class="yiv1733068921"><div class="yiv1733068921"><div class="yiv1733068921ydp351e410eyahoo-style-wrap" style="font-family:Helvetica Neue, Helvetica, Arial, sans-serif;font-size:13px;"><div class="yiv1733068921"></div>
        <div class="yiv1733068921">I think you downloaded an obsolete version from bitbucket. The current code is at <a rel="nofollow" shape="rect" class="yiv1733068921" target="_blank" href="https://github.com/moinwiki/moin">https://github.com/moinwiki/moin</a></div><div class="yiv1733068921"><br clear="none" class="yiv1733068921"></div><div class="yiv1733068921"><br clear="none" class="yiv1733068921"><div class="yiv1733068921"><br clear="none" class="yiv1733068921"></div><div class="yiv1733068921"><br clear="none" class="yiv1733068921"></div><div class="yiv1733068921"><br clear="none" class="yiv1733068921"></div></div><div class="yiv1733068921"><br clear="none" class="yiv1733068921"></div>
        
        </div><div class="yiv1733068921yahoo_quoted" id="yiv1733068921yahoo_quoted_7967369660">
            <div class="yiv1733068921" style="font-family:'Helvetica Neue', Helvetica, Arial, sans-serif;font-size:13px;color:#26282a;">
                
                <div class="yiv1733068921">
                    On Friday, May 10, 2019, 6:43:57 AM EDT, Renato Pontefice <<a rel="nofollow" shape="rect" class="yiv1733068921" ymailto="mailto:renato.pontefice@gmail.com" target="_blank" href="mailto:renato.pontefice@gmail.com">renato.pontefice@gmail.com</a>> wrote:
                </div>
                <div class="yiv1733068921"><br clear="none" class="yiv1733068921"></div>
                <div class="yiv1733068921"><br clear="none" class="yiv1733068921"></div>
                <div class="yiv1733068921"><div class="yiv1733068921" id="yiv1733068921"><div class="yiv1733068921" dir="ltr"><div class="yiv1733068921" dir="ltr"><div class="yiv1733068921" dir="ltr"><div class="yiv1733068921" dir="ltr">Hi,<br clear="none" class="yiv1733068921"></div><div class="yiv1733068921">I've downloaded moinmoin 2</div><div class="yiv1733068921">I try to install it, following the documentation.</div><div class="yiv1733068921">I run:</div><div class="yiv1733068921"><br clear="none" class="yiv1733068921"></div><blockquote class="yiv1733068921gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex;">C:\Users\renatop\moin-2.0>python quickinstall.py</blockquote><div class="yiv1733068921"><br clear="none" class="yiv1733068921"></div><div class="yiv1733068921">but finaly it doesn't works</div><div class="yiv1733068921">following are the log I obtain:</div><blockquote class="yiv1733068921gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex;"> <br clear="none" class="yiv1733068921">Usage:<br clear="none" class="yiv1733068921">  pip install [options] <requirement specifier> [package-index-options] ...<br clear="none" class="yiv1733068921">  pip install [options] -r <requirements file> [package-index-options] ...<br clear="none" class="yiv1733068921">  pip install [options] [-e] <vcs project url> ...<br clear="none" class="yiv1733068921">  pip install [options] [-e] <local project path> ...<br clear="none" class="yiv1733068921">  pip install [options] <archive url/path> ...<br clear="none" class="yiv1733068921">no such option: --download-cache<br clear="none" class="yiv1733068921">Traceback (most recent call last):<br clear="none" class="yiv1733068921">  File "quickinstall.py", line 153, in <module><br clear="none" class="yiv1733068921">    QuickInstall(os.path.dirname(os.path.realpath(sys.argv[0])), venv=args.venv, download_cache=args.download_cache)()<br clear="none" class="yiv1733068921">  File "quickinstall.py", line 68, in __call__<br clear="none" class="yiv1733068921">    self.do_install()<br clear="none" class="yiv1733068921">  File "quickinstall.py", line 108, in do_install<br clear="none" class="yiv1733068921">    subprocess.check_call(args)<br clear="none" class="yiv1733068921">  File "C:\Python27\lib\subprocess.py", line 190, in check_call<br clear="none" class="yiv1733068921">    raise CalledProcessError(retcode, cmd)<br clear="none" class="yiv1733068921">subprocess.CalledProcessError: Command '['C:\\Users\\renatop\\moin-2.0-venv-python\\Scripts\\pip', 'install', '--upgrade', '--download-cache', 'C:\\Us<br clear="none" class="yiv1733068921">ers\\renatop\\pip\\pip-download-cache', '--editable', 'C:\\Users\\renatop\\moin-2.0', '--process-dependency-links', '--allow-external', 'flatland', '-<br clear="none" class="yiv1733068921">-allow-unverified', 'flatland']' returned non-zero exit status 2<br clear="none" class="yiv1733068921">C:\Users\renatop\moin-2.0>cls</blockquote><div class="yiv1733068921"><br clear="none" class="yiv1733068921"></div><div class="yiv1733068921">what do I have to do?</div><div class="yiv1733068921"><br clear="none" class="yiv1733068921"></div><div class="yiv1733068921">TIA</div><div class="yiv1733068921"><br clear="none" class="yiv1733068921"></div><div class="yiv1733068921">Renato </div><div class="yiv1733068921"><br clear="none" class="yiv1733068921"></div></div></div></div></div>_______________________________________________<br clear="none" class="yiv1733068921">moin-user mailing list<br clear="none" class="yiv1733068921"><a rel="nofollow" shape="rect" class="yiv1733068921" ymailto="mailto:moin-user@python.org" target="_blank" href="mailto:moin-user@python.org">moin-user@python.org</a><br clear="none" class="yiv1733068921"><a rel="nofollow" shape="rect" class="yiv1733068921" target="_blank" href="https://mail.python.org/mailman/listinfo/moin-user">https://mail.python.org/mailman/listinfo/moin-user</a><br clear="none" class="yiv1733068921"></div>
            </div>
        </div></div></div></blockquote></div></div><br clear="none" class="yiv1733068921"></div></div></div></div>
            </div>
        </div></body></html>