<html><head><meta http-equiv="Content-Type" content="text/html; charset=utf-8"></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; line-break: after-white-space;" class="">Hi,<div class="">I’ve download main2 from suggested link</div><div class="">- Tried to install I</div><div class="">-created a virtualenv</div><div class="">.tried to install it on the virtuale, but I’m unable to do it.</div><div class="">This is the messages I receive:</div><div class=""><br class=""></div><div style="margin: 0px; font-stretch: normal; font-size: 14px; line-height: normal; font-family: Courier; color: rgb(255, 238, 149); background-color: rgb(95, 100, 92);" class=""><span style="font-variant-ligatures: no-common-ligatures" class="">iMac-di-Renato:moin-master renato$ python wikiconfig.py moin2/</span></div><div style="margin: 0px; font-stretch: normal; font-size: 14px; line-height: normal; font-family: Courier; color: rgb(255, 238, 149); background-color: rgb(95, 100, 92);" class=""><span style="font-variant-ligatures: no-common-ligatures" class="">Traceback (most recent call last):</span></div><div style="margin: 0px; font-stretch: normal; font-size: 14px; line-height: normal; font-family: Courier; color: rgb(255, 238, 149); background-color: rgb(95, 100, 92);" class=""><span style="font-variant-ligatures: no-common-ligatures" class="">  File "wikiconfig.py", line 36, in <module></span></div><div style="margin: 0px; font-stretch: normal; font-size: 14px; line-height: normal; font-family: Courier; color: rgb(255, 238, 149); background-color: rgb(95, 100, 92);" class=""><span style="font-variant-ligatures: no-common-ligatures" class="">    from moin.config.default import DefaultConfig, _default_password_checker</span></div><div class=""><span style="color: rgb(255, 238, 149); font-family: Courier; font-size: 14px; background-color: rgb(95, 100, 92);" class="">ImportError: No module named moin.config.default</span>t</div><div class=""><br class=""></div><div class="">Now, I’m trying on my iMac </div><div class=""><br class=""></div><div class="">What I can do now? :-(</div><div class=""><br class=""></div><div class="">TIA</div><div class=""><br class=""></div><div class="">Renato<br class=""><div><br class=""><blockquote type="cite" class=""><div class="">Il giorno 10 mag 2019, alle ore 15:58, Roger Haase <<a href="mailto:crosseyedpenguin@yahoo.com" class="">crosseyedpenguin@yahoo.com</a>> ha scritto:</div><br class="Apple-interchange-newline"><div class=""><div class=""><div class="ydp351e410eyahoo-style-wrap" style="font-family: Helvetica Neue, Helvetica, Arial, sans-serif; font-size: 13px;"><div class=""></div>
        <div class="">I think you downloaded an obsolete version from bitbucket. The current code is at <a href="https://github.com/moinwiki/moin" rel="nofollow" target="_blank" class="">https://github.com/moinwiki/moin</a></div><div class=""><br class=""></div><div class=""><br class=""><div class=""><br class=""></div><div class=""><br class=""></div><div class=""><br class=""></div></div><div class=""><br class=""></div>
        
        </div><div id="yahoo_quoted_7967369660" class="yahoo_quoted">
            <div style="font-family:'Helvetica Neue', Helvetica, Arial, sans-serif;font-size:13px;color:#26282a;" class="">
                
                <div class="">
                    On Friday, May 10, 2019, 6:43:57 AM EDT, Renato Pontefice <<a href="mailto:renato.pontefice@gmail.com" class="">renato.pontefice@gmail.com</a>> wrote:
                </div>
                <div class=""><br class=""></div>
                <div class=""><br class=""></div>
                <div class=""><div id="yiv9156336331" class=""><div dir="ltr" class=""><div dir="ltr" class=""><div dir="ltr" class=""><div dir="ltr" class="">Hi,<br class=""></div><div class="">I've downloaded moinmoin 2</div><div class="">I try to install it, following the documentation.</div><div class="">I run:</div><div class=""><br class=""></div><blockquote class="yiv9156336331gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex;">C:\Users\renatop\moin-2.0>python quickinstall.py</blockquote><div class=""><br class=""></div><div class="">but finaly it doesn't works</div><div class="">following are the log I obtain:</div><blockquote class="yiv9156336331gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex;"> <br class="">Usage:<br class="">  pip install [options] <requirement specifier> [package-index-options] ...<br class="">  pip install [options] -r <requirements file> [package-index-options] ...<br class="">  pip install [options] [-e] <vcs project url> ...<br class="">  pip install [options] [-e] <local project path> ...<br class="">  pip install [options] <archive url/path> ...<br class="">no such option: --download-cache<br class="">Traceback (most recent call last):<br class="">  File "quickinstall.py", line 153, in <module><br class="">    QuickInstall(os.path.dirname(os.path.realpath(sys.argv[0])), venv=args.venv, download_cache=args.download_cache)()<br class="">  File "quickinstall.py", line 68, in __call__<br class="">    self.do_install()<br class="">  File "quickinstall.py", line 108, in do_install<br class="">    subprocess.check_call(args)<br class="">  File "C:\Python27\lib\subprocess.py", line 190, in check_call<br class="">    raise CalledProcessError(retcode, cmd)<br class="">subprocess.CalledProcessError: Command '['C:\\Users\\renatop\\moin-2.0-venv-python\\Scripts\\pip', 'install', '--upgrade', '--download-cache', 'C:\\Us<br class="">ers\\renatop\\pip\\pip-download-cache', '--editable', 'C:\\Users\\renatop\\moin-2.0', '--process-dependency-links', '--allow-external', 'flatland', '-<br class="">-allow-unverified', 'flatland']' returned non-zero exit status 2<br class="">C:\Users\renatop\moin-2.0>cls</blockquote><div class=""><br class=""></div><div class="">what do I have to do?</div><div class=""><br class=""></div><div class="">TIA</div><div class=""><br class=""></div><div class="">Renato </div><div class=""><br class=""></div></div></div></div></div>_______________________________________________<br class="">moin-user mailing list<br class=""><a ymailto="mailto:moin-user@python.org" href="mailto:moin-user@python.org" class="">moin-user@python.org</a><br class=""><a href="https://mail.python.org/mailman/listinfo/moin-user" target="_blank" class="">https://mail.python.org/mailman/listinfo/moin-user</a><br class=""></div>
            </div>
        </div></div></div></blockquote></div><br class=""></div></body></html>