[New-bugs-announce] [issue1110] Problems with the msi installer - python-3.0a1.msi

Vlastimil Brom report at bugs.python.org
Wed Sep 5 20:20:07 CEST 2007


New submission from Vlastimil Brom:

I encountered problems installing python 3.0 alpha 1 from the MSI 
installer supplied on the python download page (python-3.0a1.msi). 
If the advanced option of the installer ("compile .py files to bytecode 
after installation") is checked - the following message is shown
"There is a problem with this Windows installer package. A program run 
as part of the setup did not finish as expected ..."
If I don't choose the option to compile files, the installation 
finishes without any visible errors.

The result is in both cases the same however. After calling python.exe 
it shows the version info etc. in the interactive prompt, but it 
doesn't "respond" in any way.
e.g.
>>> 1+1
object  : RuntimeError('lost sys.stdout',)
type    : RuntimeError
refcount: 4
address : 00A65BD0
lost sys.stderr
>>> 

Running of any .py file doesn't work either.

My system is Win XPh SP2 Czech (the same on Win XPp SP2 Czech).

Could possibly the Czech windows version/ language setting/ locale/ 
timezone or whatever be the problem (as there were some problems 
reported with the manual compilation on German or Polish Winsows-
systems)?

Or am I missing something trivial?

Thanks,
 Vlastimil Brom

----------
components: Windows
messages: 55665
nosy: vbr
severity: normal
status: open
title: Problems with the msi installer - python-3.0a1.msi
versions: Python 3.0

__________________________________
Tracker <report at bugs.python.org>
<http://bugs.python.org/issue1110>
__________________________________


More information about the New-bugs-announce mailing list