[New-bugs-announce] [issue2708] IDLE subprocess error

Kristian Lauridsen report at bugs.python.org
Mon Apr 28 16:10:41 CEST 2008

New submission from Kristian Lauridsen <diablos_pitbull at hotmail.com>:

Hi all.
I'w been looking for an answer to this. 
If I use IDLE for som "just fore fun" programming and then exit, I have 
to "kill" IDLE, dispite theres nothin "running" persay, then when i 
start IDLE again I get too error messages popping up:

1: Socket Error: Connection refused
2: IDLE's subprocess didn't make connection. Either IDLE can't start a 
subprocess or personal firewall is blocking the connection.

The code written in IDLE that triggers the problem can be something 
simple like:
>>> a = 'hello world'
>>> print a

I have to reboot to get past the error.
I'm only getting the error when running vista and xp theres no problom 
in any of the other systems i'v tried (mainly linux)
I should mention that the error dosn't come every time I "kill" IDLE, I 
would say about every 3rd run, or there about.
I'v tried removeing/killing windows owen firewall and then running IDLE 
but with the same result.
Like I said, i been look around fore a "fix" fore this but havent found 
If I have made a "double post" please let me know and remove this 

components: IDLE
messages: 65918
nosy: Kris
severity: normal
status: open
title: IDLE subprocess error
type: crash
versions: Python 2.5

Tracker <report at bugs.python.org>

More information about the New-bugs-announce mailing list