[New-bugs-announce] [issue3565] array documentation, method names not 3.0 compliant

"Martin v. Löwis" martin at v.loewis.de
Sat Aug 16 11:22:31 CEST 2008

> 2. Rename "tostring" and "fromstring" methods to "tobytes" and
> "frombytes". I think this is quite important as the value being returned
> can no longer be described as a "string".

I'm not a native speaker (of English), but my understanding is that the
noun "string", in itself, can very well be used to describe this type:
the result is a "byte string", as opposed to a "character string".
Merriam-Webster's seems to agree; meaning 5b(2) is "a sequence of like
items (as bits, characters, or words)"

More information about the New-bugs-announce mailing list