[New-bugs-announce] [issue4625] IDLE won't open anymore, .idlerc unaccessible

Sophia K. Cheng report at bugs.python.org
Thu Dec 11 04:30:22 CET 2008

New submission from Sophia K. Cheng <sophia.cheng at gmail.com>:


I was able to run IDLE once or twice on my laptop.  Then I downloaded
kiki and tried to run it but had forgotten to install wxPython.  After
that, IDLE no longer opens although the command prompt does still work.
 I get the following error:

C:\Python25>python.exe Lib\idlelib\idle.py
Traceback (most recent call last):
  File "Lib\idlelib\idle.py", line 21, in <module>
  File "C:\Python25\lib\idlelib\PyShell.py", line 1404, in main
    shell = flist.open_shell()
  File "C:\Python25\lib\idlelib\PyShell.py", line 275, in open_shell
    self.pyshell = PyShell(self)
  File "C:\Python25\lib\idlelib\PyShell.py", line 813, in __init__
    OutputWindow.__init__(self, flist, None, None)
  File "C:\Python25\lib\idlelib\OutputWindow.py", line 16, in __init__
    EditorWindow.__init__(self, *args)
  File "C:\Python25\lib\idlelib\EditorWindow.py", line 248, in __init__
  File "C:\Python25\lib\idlelib\EditorWindow.py", line 715, in
    rf_file = open(self.recent_files_path, 'w')
IOError: [Errno 13] Permission denied: 'C:\\Documents and

I've tried uninstalling and reinstalling several times 2.5 and also 2.6.
 When I look at the folder .idlerc in windows explorer, I get an error
each time I click on it that access is denied, even though I am running
as administrator on my laptop. I have tried uninstalling Python and
deleting the .idlerc folder.  I have also tried manually unchecking the
read-only property for the folder. I have a Lenovo T400 that is built
for Windows Vista, but am running Windows XP.  Thank you.

components: IDLE
messages: 77588
nosy: skcheng
severity: normal
status: open
title: IDLE won't open anymore, .idlerc unaccessible
versions: Python 2.5.3

Python tracker <report at bugs.python.org>

More information about the New-bugs-announce mailing list