[New-bugs-announce] [issue4017] IDLE 2.6 broken on OSX (Leopard)

Fabio FZero report at bugs.python.org
Thu Oct 2 17:16:30 CEST 2008

New submission from Fabio FZero <fabio.fzero+python at gmail.com>:

I've just installed Python 2.6 on Mac OS X 10.5.5 and IDLE won't start.
IDLE 2.5 still works fine.

Here's the traceback:

Traceback (most recent call last):
  File "/Library/Frameworks/Python.framework/Versions/Current/bin/idle",
line 3, in <module>
    from idlelib.PyShell import main
line 14, in <module>
    import macosxSupport
line 6, in <module>
    import Tkinter
line 39, in <module>
    import _tkinter # If this fails your Python may not be configured for Tk
2): Library not loaded: /Library/Frameworks/Tcl.framework/Versions/8.5/Tcl
  Referenced from:
  Reason: image not found

components: IDLE
messages: 74166
nosy: fzero
severity: normal
status: open
title: IDLE 2.6 broken on OSX (Leopard)
type: crash
versions: Python 2.6

Python tracker <report at bugs.python.org>

More information about the New-bugs-announce mailing list