[New-bugs-announce] [issue4208] Make multiprocessing compatible with Python 2.4 and 2.5

Christian Heimes report at bugs.python.org
Sun Oct 26 16:21:14 CET 2008

New submission from Christian Heimes <lists at cheimes.de>:

The patch contains all differences between our multiprocessing backport
to 2.4 / 2.5 and the release26-maint branch. The patch should NOT be
applied yet. I've created the patch to discuss the differences.

Several changes could be avoided by monkey patching the threading module
of Python 2.4 and 2.5. Other changes are required like using the old
buffer protocol.

components: Interpreter Core, Library (Lib)
files: mp_py25_compat.diff
keywords: patch, patch
messages: 75231
nosy: christian.heimes, jnoller, skip.montanaro
priority: low
severity: normal
status: open
title: Make multiprocessing compatible with Python 2.4 and 2.5
type: feature request
versions: Python 2.6, Python 2.7
Added file: http://bugs.python.org/file11891/mp_py25_compat.diff

Python tracker <report at bugs.python.org>

More information about the New-bugs-announce mailing list