[New-bugs-announce] [issue6140] configure error: shadow.h: present but cannot be compiled

Sashi report at bugs.python.org
Fri May 29 03:20:59 CEST 2009

New submission from Sashi <sashi at voltage.com>:

Got the following error while building Python 2.5.2 on HP-UX 11.11

bash-3.2$ uname -a
HP-UX hpux B.11.11 U 9000/785 2010988722 unlimited-user license

configure: WARNING:

  By default, distutils will build C++ extension modules with "g++".
  If this is not intended, then set CXX on the configure command line.

configure: WARNING: shadow.h: present but cannot be compiled
configure: WARNING: shadow.h:     check for missing prerequisite headers?
configure: WARNING: shadow.h: see the Autoconf documentation
configure: WARNING: shadow.h:     section "Present But Cannot Be Compiled"
configure: WARNING: shadow.h: proceeding with the preprocessor's result
configure: WARNING: shadow.h: in the future, the compiler will take
configure: WARNING:     ##
------------------------------------------------ ##
configure: WARNING:     ## Report this to
http://www.python.org/python-bugs ##
configure: WARNING:     ##
------------------------------------------------ ##
creating Modules/Setup
creating Modules/Setup.local
creating Makefile

components: Build
messages: 88491
nosy: Sashi
severity: normal
status: open
title: configure error: shadow.h: present but cannot be compiled
type: compile error
versions: Python 2.5

Python tracker <report at bugs.python.org>

More information about the New-bugs-announce mailing list