[New-bugs-announce] [issue7217] IDLE Subprocess Startup Error

ali report at bugs.python.org
Tue Oct 27 08:57:05 CET 2009

New submission from ali <mr.dalba at gmail.com>:


After trying to install another IDE for python (Eric4.3.8 and sciTE201)
I'm not able to launch IDLE directly anymore. (I not sure if this is
really relevant)

I can right click on the .py files and choose "edit with IDLE" and
everything works fine.

Also, I can run python under cmd without any problem.

But when I try to open IDLE using start menu icon, this error massage

Subprocess Startup Error
IDLE's subprocess didn't make connection. either idle can't start a
subprocess or personal firewall software is blocking the connection.

I tried to disable my anti-virus and windows firewall (I don't use any
other firewalls), but the problem still exists.

I uninstalled python 2.6.2 and then installed python 3.1.1. IDLE worked
fine but I had a little problem with the new syntax in python 3 so I
installed python 2.6.4 and guess what, the same error message again!

When I try to run IDLE from cmd this error message is displayed:

Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "C:\Python26\lib\idlelib\run.py", line 13, in <module>
    import RemoteDebugger
  File "C:\Python26\lib\idlelib\RemoteDebugger.py", line 24, in <module>
    import rpc
  File "C:\Python26\lib\idlelib\rpc.py", line 120, in <module>
    request_queue = Queue.Queue(0)
TypeError: __init__() takes exactly 1 argument (2 given)

Can anyone help?
Thanks in advance

components: IDLE
messages: 94546
nosy: mr.dalba
severity: normal
status: open
title: IDLE Subprocess Startup Error
type: crash
versions: Python 2.6

Python tracker <report at bugs.python.org>

More information about the New-bugs-announce mailing list