[New-bugs-announce] [issue8927] Cannot handle complex requirement resolution

Dave Abrahams report at bugs.python.org
Sun Jun 6 21:37:40 CEST 2010


New submission from Dave Abrahams <dave at boostpro.com>:

[This looks like a bug report against PIP because Tarek told me distutils2 would be responsible for this kind of thing and that there was an open ticket for it.  However, I can't find any such ticket so I'm posting it here]

Not only does pip not check for conflicts as noted in http://bitbucket.org/ianb/pip/src/tip/pip/req.py#cl-928, it doesn't consider any requirements on a package other than the first. So if I have

A requires B and C
B requires D<=1.1
C requires D<=0.9

installing A will give us D==1.1 rather than D==0.9

Once responsibility for this functionality is sorted out, we may be able to close this ticket or http://bitbucket.org/ianb/pip/issue/119

----------
assignee: tarek
components: Distutils2
messages: 107214
nosy: dabrahams, tarek
priority: normal
severity: normal
status: open
title: Cannot handle complex requirement resolution
type: behavior
versions: Python 2.6

_______________________________________
Python tracker <report at bugs.python.org>
<http://bugs.python.org/issue8927>
_______________________________________


More information about the New-bugs-announce mailing list