[New-bugs-announce] [issue9059] Backwards compatibility

Raven Demeyer report at bugs.python.org
Wed Jun 23 11:51:13 CEST 2010

New submission from Raven Demeyer <raven.demeyer at gmail.com>:

Python 3 is not backwards compatible with Python 2.

Python 2: print 'foo'
Python 3: print(bar)

Code written for Python during version 2 cannot be used/compiled in version 3

Just like any decent self-respecting programming language, add backwards compatibility.

components: Regular Expressions
messages: 108444
nosy: Raven
priority: normal
severity: normal
status: open
title: Backwards compatibility
type: compile error
versions: Python 3.1

Python tracker <report at bugs.python.org>

More information about the New-bugs-announce mailing list