[New-bugs-announce] [issue10555] Fatal Python error: Interpreter not initialized (version mismatch?)

Anurag Chourasia report at bugs.python.org
Sat Nov 27 22:42:03 CET 2010

New submission from Anurag Chourasia <anurag.chourasia at gmail.com>:

Python extensions build on AIX 5.3 with GCC 4.2 fails.

The configure command was as follows

./configure --enable-shared --disable-ipv6 --with-gcc=gcc CPPFLAGS="-I /opt/freeware/include -I /opt/freeware/include/readline -I /opt/freeware/include/ncurses" LDFLAGS="-L. -L/usr/local/lib"

The error during the make step was as follows

running build
running build_ext
ldd: /lib/libreadline.a: File is an archive.
building dbm using ndbm
INFO: Can't locate Tcl/Tk libs and/or headers
building '_struct' extension
creating build
creating build/temp.aix-5.3-2.7
creating build/temp.aix-5.3-2.7/u01
creating build/temp.aix-5.3-2.7/u01/home
creating build/temp.aix-5.3-2.7/u01/home/apli
creating build/temp.aix-5.3-2.7/u01/home/apli/wm
creating build/temp.aix-5.3-2.7/u01/home/apli/wm/GDD
creating build/temp.aix-5.3-2.7/u01/home/apli/wm/GDD/Python-2.7
creating build/temp.aix-5.3-2.7/u01/home/apli/wm/GDD/Python-2.7/Modules
gcc -pthread -fno-strict-aliasing -g -O2 -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -I. -IInclude -I./Include -I/opt/freeware/include -I/opt/freeware/include/readline -I/opt/freeware/include/ncurses -I/usr/local/include -I/u01/home/apli/wm/GDD/Python-2.7/Include -I/u01/home/apli/wm/GDD/Python-2.7 -c /u01/home/apli/wm/GDD/Python-2.7/Modules/_struct.c -o build/temp.aix-5.3-2.7/u01/home/apli/wm/GDD/Python-2.7/Modules/_struct.o
creating build/lib.aix-5.3-2.7
./Modules/ld_so_aix gcc -pthread -bI:Modules/python.exp -L. -L/usr/local/lib build/temp.aix-5.3-2.7/u01/home/apli/wm/GDD/Python-2.7/Modules/_struct.o -L. -L/usr/local/lib -lpython2.7 -o build/lib.aix-5.3-2.7/_struct.so
Fatal Python error: Interpreter not initialized (version mismatch?)
make: 1254-059 The signal code from the last command is 6.

The file build/lib.aix-5.3-2.7/_struct.so is present after this error. 

The error seems to be in importing the module that was just built. Here is the error message from the python executable that was built.

root [zibal]% pwd
root [zibal]% which python
root [zibal]% python
Python 2.7 (r27:82500, Nov 27 2010, 18:33:21)
[GCC 4.2.4] on aix5
Type "help", "copyright", "credits" or "license" for more information.
>>> import struct
Fatal Python error: Interpreter not initialized (version mismatch?)
IOT/Abort trap(coredump)

This is also an error in Version 2.6.6

I don't have any other conflicting python library that might cause this.

components: Build
messages: 122561
nosy: Anurag.Chourasia
priority: normal
severity: normal
status: open
title: Fatal Python error: Interpreter not initialized (version mismatch?)
type: compile error
versions: Python 2.7

Python tracker <report at bugs.python.org>

More information about the New-bugs-announce mailing list