[New-bugs-announce] [issue10236] Sporadic failures of test_ssl

Stephen Hansen report at bugs.python.org
Fri Oct 29 21:46:55 CEST 2010


New submission from Stephen Hansen <me+python at ixokai.io>:

Another sporadic failure I've noticed since setting up my buildbot; test_ssl keeps going down. This one I have a hard time analyzing with the tests output, but the latest is: 
http://www.python.org/dev/buildbot/all/builders/x86%20Snow%20Leopard%203.x/builds/250

There's this part in the log:

test_get_server_certificate (test.test_ssl.NetworkedTests) ... [Errno 1] _ssl.c:390: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed

Verified certificate for svn.python.org:443 is
[...pem...]
ok

There's an errno printed there, but then more debugging for that same test-- and an 'ok'-- so I don't see the FAIL message I'm expecting. So to my naive reading, it seems that it is running once and failing, then re-running in verbose and /not/ failing (and that the error-like message there may not be an error). So, the original problem is a mystery.

Or I'm totally reading it wrong. Either way, I've seen this several times and am not sure how to further debug it. Any suggestions or pointers are welcome. Or fixes :)

----------
messages: 119932
nosy: ixokai
priority: normal
severity: normal
status: open
title: Sporadic failures of test_ssl
versions: Python 3.2

_______________________________________
Python tracker <report at bugs.python.org>
<http://bugs.python.org/issue10236>
_______________________________________


More information about the New-bugs-announce mailing list