[New-bugs-announce] [issue9728] Docs point to FAQ Section 3, but FAQs are not numbered

Daniel Stutzbach report at bugs.python.org
Wed Sep 1 03:49:09 CEST 2010

New submission from Daniel Stutzbach <daniel at stutzbachenterprises.com>:

In Doc/extending/windows.rst, there's the following text:

If your module creates a new type, you may have trouble with this line::

   PyVarObject_HEAD_INIT(&PyType_Type, 0)

Change it to::

   PyVarObject_HEAD_INIT(NULL, 0)

and add the following to the module initialization function::

   MyObject_Type.ob_type = &PyType_Type;

Refer to section 3 of the `Python FAQ <http://www.python.org/doc/faq>`_ for
details on why you must do this.

If I assume that Section 3 means, the third link on the FAQ page, I can't find the FAQ that's being alluded to here.  There's a comment in Include/pyport.h that I believe to be related:

            /* Under Cygwin, auto-import functions to prevent compilation */
            /* failures similar to http://python.org/doc/FAQ.html#3.24 */

However, that link no longer goes to a particular question and I can't tell which question it once referred to.

I ran into this because I'm trying to understand the cause of the issue which I suspect is related to Issue #6672.

assignee: docs at python
components: Documentation
messages: 115285
nosy: brian.curtin, docs at python, stutzbach, tim.golden
priority: normal
severity: normal
stage: needs patch
status: open
title: Docs point to FAQ Section 3, but FAQs are not numbered

Python tracker <report at bugs.python.org>

More information about the New-bugs-announce mailing list