[New-bugs-announce] [issue13588] Change name of internal closure functions in importlib

Brett Cannon report at bugs.python.org
Mon Dec 12 16:32:34 CET 2011


New submission from Brett Cannon <brett at python.org>:

The internal closure functions (eg. wrapper functions used by decorators) should not use generic names like inner() or wrapper(), but descriptive names so that they make sense when read in a traceback. IOW, you shouldn't have to look up the source code to figure out what decorator's wrapper is found in the traceback.

----------
components: Library (Lib)
keywords: easy
messages: 149315
nosy: brett.cannon
priority: low
severity: normal
stage: needs patch
status: open
title: Change name of internal closure functions in importlib
type: feature request
versions: Python 3.3

_______________________________________
Python tracker <report at bugs.python.org>
<http://bugs.python.org/issue13588>
_______________________________________


More information about the New-bugs-announce mailing list