[New-bugs-announce] [issue11347] libpython3.so: Broken soname and linking

Arfrever Frehtes Taifersar Arahesis report at bugs.python.org
Sun Feb 27 21:26:28 CET 2011

New submission from Arfrever Frehtes Taifersar Arahesis <Arfrever.FTA at GMail.Com>:

1. libpython3.so has soname "llibpython3.so" due to needless "l" in "-Wl,-hl$@".
2. libpython3.so is not linked against libpython$(LDVERSION).so when -Wl,--as-needed flag is used. -Wl,--as-needed flag is used by default in Gentoo due to major benefits.
>From `info ld`:
     This option affects ELF DT_NEEDED tags for dynamic libraries
     mentioned on the command line after the `--as-needed' option.
     Normally the linker will add a DT_NEEDED tag for each dynamic
     library mentioned on the command line, regardless of whether the
     library is actually needed or not.  `--as-needed' causes a
     DT_NEEDED tag to only be emitted for a library that satisfies an
     undefined symbol reference from a regular object file or, if the
     library is not found in the DT_NEEDED lists of other libraries
     linked up to that point, an undefined symbol reference from
     another dynamic library.  `--no-as-needed' restores the default

I'm attaching the patch.

components: Build
files: libpython3.so.patch
keywords: patch
messages: 129649
nosy: Arfrever, loewis
priority: normal
severity: normal
status: open
title: libpython3.so: Broken soname and linking
versions: Python 3.2, Python 3.3
Added file: http://bugs.python.org/file20939/libpython3.so.patch

Python tracker <report at bugs.python.org>

More information about the New-bugs-announce mailing list